summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspicylemonade2022-07-27 06:57:41 -0400
committerspicylemonade2022-07-27 06:57:41 -0400
commita9a58cbb612a221f7de83f5e6075c7da05095763 (patch)
tree4d5eb606c69749a7be0a38720dd32fe232d1b21d
downloadaur-a9a58cbb612a221f7de83f5e6075c7da05095763.tar.gz
"Initial"
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7bd031fa3a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = punch-git
+ pkgdesc = file and folder management written in rust
+ pkgver = 1.7.5
+ pkgrel = 1
+ url = https://github.com/spicylemonade/punch.git
+ arch = x86_64
+ license = MIT
+ depends = rustup
+ source = git+https://github.com/spicylemonade/punch.git
+ md5sums = SKIP
+
+pkgname = punch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f142b7c5203e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=punch-git
+pkgver=$(git describe --tags)
+pkgrel=1
+epoch=
+pkgdesc="file and folder management written in rust"
+arch=(x86_64)
+url="https://github.com/spicylemonade/punch.git"
+license=('MIT')
+groups=()
+depends=(rustup)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+package() {
+ cd "punch"
+ . ./build.sh
+}