summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrvyx2020-02-07 23:12:18 -0800
committerOrvyx2020-02-07 23:12:18 -0800
commit9b5abc85a08e773bb52989ee2e0670203f8ad569 (patch)
tree46b74bd3356199fd00abdef50452a3f5e0474acf
downloadaur-9b5abc85a08e773bb52989ee2e0670203f8ad569.tar.gz
initial add of bolt, built from git repo, to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67d0f6665c0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = puppet-bolt-git
+ pkgdesc = Bolt is an orchestration tool that automates remote nodes with SSH or WinRM
+ pkgver = 1.48.0.r21.g9064dbe6
+ pkgrel = 1
+ url = https://github.com/puppetlabs/bolt
+ arch = x86_64
+ license = Apache
+ makedepends = ruby
+ makedepends = git
+ conflicts = puppet-bolt
+ source = git+https://github.com/puppetlabs/bolt
+ sha256sums = SKIP
+
+pkgname = puppet-bolt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..853e503bc584
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Drew Ortega <orvyx@protonmail.com>
+
+pkgname=puppet-bolt-git
+pkgver=1.48.0.r21.g9064dbe6
+pkgrel=1
+pkgdesc='Bolt is an orchestration tool that automates remote nodes with SSH or WinRM'
+arch=('x86_64')
+url='https://github.com/puppetlabs/bolt'
+license=('Apache')
+makedepends=('ruby' 'git')
+source=('git+https://github.com/puppetlabs/bolt')
+sha256sums=('SKIP')
+
+conflicts=('puppet-bolt')
+
+build() {
+ gem install net-ssh-krb
+ cd "bolt"
+ gem build
+}
+
+package() {
+ cd "bolt"
+ gem install --local ./bolt-*.gem
+}
+
+pkgver() {
+ cd "bolt"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}