summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2018-01-26 07:14:29 -0500
committerMario Finelli2018-01-26 07:14:29 -0500
commit1f372d95e16ed2a8edcb610cf3f2cf85df16cff1 (patch)
tree051e21e17d435d02b8a3ec432cd4fa6775a406fd
parent0ef29847753c1b2d488001dbb68d39a51799ed79 (diff)
downloadaur-1f372d95e16ed2a8edcb610cf3f2cf85df16cff1.tar.gz
Fix broken packaging
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 587aef67e5e9..b08f5289ff9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = puppet-lint
pkgdesc = Check that your Puppet manifests conform to the style guide.
pkgver = 2.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rodjek/puppet-lint
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7e38136ec4d0..eb0145d63c52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=puppet-lint
pkgver=2.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Check that your Puppet manifests conform to the style guide."
arch=('i686' 'x86_64')
url="https://github.com/rodjek/puppet-lint"
@@ -14,8 +14,7 @@ noextract=($pkgname-$pkgver.gem)
sha256sums=('8d3f294b1220253580ec7b19ff8a88e2065566d3da47adbefd88a7e178796e23')
package() {
- cd "$srcdir"
- local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
-
- gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$pkgname-$pkgver.gem"
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $pkgname-$pkgver.gem
+ rm "$pkgdir/$_gemdir/cache/$pkgname-$pkgver.gem"
}