summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-06-09 08:22:56 -0400
committerMario Finelli2015-06-09 08:22:56 -0400
commitf1cd824116fdd5070c6c220f3fc5871e1386cca4 (patch)
treefa4fc9ffd44cca1d6de7738739f62ac71a8018b4
downloadaur-f1cd824116fdd5070c6c220f3fc5871e1386cca4.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79355bcecb97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = puppet-lint
+ pkgdesc = Check that your Puppet manifests conform to the style guide.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/rodjek/puppet-lint
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rubygems
+ depends = ruby
+ noextract = puppet-lint-1.1.0.gem
+ source = https://rubygems.org/downloads/puppet-lint-1.1.0.gem
+ sha256sums = 739f566cd4f1e77b92c1191217fdb59ce12353f3ec2703f30933d2bba877b35b
+
+pkgname = puppet-lint
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8591fc960440
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+pkgname=puppet-lint
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Check that your Puppet manifests conform to the style guide."
+arch=('i686' 'x86_64')
+url="https://github.com/rodjek/puppet-lint"
+license=('MIT')
+depends=('ruby')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$pkgname-$pkgver.gem)
+noextract=($pkgname-$pkgver.gem)
+sha256sums=('739f566cd4f1e77b92c1191217fdb59ce12353f3ec2703f30933d2bba877b35b')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$pkgname-$pkgver.gem"
+}