summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL. Bradley LaBoon2019-03-22 10:31:33 -0400
committerL. Bradley LaBoon2019-03-22 10:31:33 -0400
commit770e7690447d431b40353c1355f5c42f199a9b24 (patch)
tree7888673c3a27c2fa0cc1dfe678b754c5e2f83ff0
parent17d8892c681348bac891b868aa1709e6e5158efc (diff)
downloadaur-770e7690447d431b40353c1355f5c42f199a9b24.tar.gz
Fixed ruby path references in some gems
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a337a7bd543d..6fa0478d0c83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=puppetserver
pkgver=6.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Server automation framework and application"
arch=('any')
url="https://docs.puppetlabs.com/puppetserver/latest/services_master_puppetserver.html"
@@ -38,6 +38,10 @@ prepare() {
sed -i "s:\[/opt/puppetlabs/puppet/lib/ruby/vendor_ruby\]:\[$( ruby -e \
'puts RbConfig::CONFIG["vendorlibdir"]' ),$( ruby -e \
'puts RbConfig::CONFIG["vendordir"]' )\]:" "ext/config/conf.d/${pkgname}.conf"
+ sed -i "s:/opt/puppetlabs/puppet/lib/ruby/vendor_gems:$( ruby -e \
+ 'puts Gem.default_dir' ):" \
+ ext/build-scripts/install-vendored-gems.sh
+ sed -i 's:#!/opt/.*/ruby:#!/usr/bin/ruby:' ext/cli/ca
}
package() {