summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2022-08-04 02:46:23 +0200
committerAlbert Graef2022-08-04 02:46:23 +0200
commitc54ea6001a962e16f11580565043cafa310db7da (patch)
tree33179d6ea6376e2f1ce1f266dbfe217647d294dd
parente9266152dcc169f58240fece229df4e765076fe9 (diff)
downloadaur-pure.tar.gz
Fixes for Emacs 27 compatibility.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--emacs27.patch44
3 files changed, 57 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a0ca5dfb361..2e9164c6b75b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sat Feb 16 15:52:35 UTC 2019
pkgbase = pure
pkgdesc = Pure is a modern-style functional programming language based on term rewriting.
pkgver = 0.68
- pkgrel = 3
+ pkgrel = 4
url = http://purelang.bitbucket.org/
arch = i686
arch = x86_64
@@ -23,7 +21,8 @@ pkgbase = pure
optdepends = emacs-pure-mode: editing Pure files from Emacs
optdepends = texmacs-pure: embedding Pure sessions in TeXmacs
source = https://github.com/agraef/pure-lang/releases/download/pure-0.68/pure-0.68.tar.gz
+ source = emacs27.patch
md5sums = 082d522d05e58e55dc8094ba4c3d3eda
+ md5sums = fe62166e277a6accefbfa81e2e307900
pkgname = pure
-
diff --git a/PKGBUILD b/PKGBUILD
index 4033314843a0..ccc6335ff738 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=pure
pkgver=0.68
-pkgrel=3
+pkgrel=4
pkgdesc="Pure is a modern-style functional programming language based on term rewriting."
arch=("i686" "x86_64")
license=('GPL3' 'LGPL3')
@@ -20,8 +20,15 @@ optdepends=("clang35: needed for inlining C/C++ code"
"emacs-pure-mode: editing Pure files from Emacs"
"texmacs-pure: embedding Pure sessions in TeXmacs")
groups=(pure-complete pure-base)
-source=("https://github.com/agraef/pure-lang/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('082d522d05e58e55dc8094ba4c3d3eda')
+source=("https://github.com/agraef/pure-lang/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+ "emacs27.patch")
+md5sums=('082d522d05e58e55dc8094ba4c3d3eda'
+ 'fe62166e277a6accefbfa81e2e307900')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p2 -i ../emacs27.patch
+}
build() {
cd $srcdir/$pkgname-$pkgver
diff --git a/emacs27.patch b/emacs27.patch
new file mode 100644
index 000000000000..9850bdcb277b
--- /dev/null
+++ b/emacs27.patch
@@ -0,0 +1,44 @@
+diff --git a/pure/etc/flycheck-pure.el b/pure/etc/flycheck-pure.el
+index 152489ae..448d12d2 100644
+--- a/pure/etc/flycheck-pure.el
++++ b/pure/etc/flycheck-pure.el
+@@ -60,7 +60,7 @@
+ "A Pure syntax checker using the Pure interpreter.
+
+ See URL `https://agraef.github.io/pure-lang/'."
+- :command ("pure" "--check" (option-flag "-w" flycheck-pure-warnings) source)
++ :command ("pure" "--check" "-I." (option-flag "-w" flycheck-pure-warnings) source)
+ :error-patterns
+ ((warning line-start (file-name) ", line " line ": warning: " (message) line-end)
+ (error line-start (file-name) ", line " line ": " (message) line-end))
+diff --git a/pure/etc/pure-mode.el.in b/pure/etc/pure-mode.el.in
+index 221bfa52..5807a43a 100644
+--- a/pure/etc/pure-mode.el.in
++++ b/pure/etc/pure-mode.el.in
+@@ -874,7 +874,7 @@ Commands
+ "Starts a pdsend process to communicate with Pd via UDP port 4711."
+ (interactive)
+ (start-process "pdsend" nil "pdsend" "4711" "localhost" "udp")
+- (process-kill-without-query (get-process "pdsend")))
++ (set-process-query-on-exit-flag (get-process "pdsend") nil))
+
+ (defun pd-pure-send-stop-process ()
+ "Stops a previously started pdsend process."
+@@ -1421,7 +1421,7 @@ sending input, manipulating the command history, etc."
+ pure-last-dir dir)
+ (set-process-sentinel (get-process "pure-eval") 'pure-eval-sentinel)
+ (if (not pure-query-before-kill)
+- (process-kill-without-query (get-process "pure-eval")))
++ (set-process-query-on-exit-flag (get-process "pure-eval") nil))
+ ;; switch to and go to the end of the eval buffer
+ (pop-to-buffer "*pure-eval*")
+ (goto-char (point-max))
+@@ -2270,7 +2270,7 @@ If prefix ARG is not nil, remove an existing tracepoint instead."
+ (indent-to (eval (cdr indent-fun)))
+ ))))
+
+-(defun pure-alignment-column (&optional lim &optional flag)
++(defun pure-alignment-column (&optional lim flag)
+ "Look for an alignment column (`=') in the vicinity of
+ point. LIM, if given, limits the search to the region between
+ point and LIM. Return a list of two elements: (EQUALS-COL