summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-04-05 00:29:01 +0200
committerAlbert Graef2016-04-05 00:29:01 +0200
commitd8ec3905565c992833c763281c5db127fcf1e869 (patch)
tree78446eb7d792aeede34b5ac73f989bb135ce4f3d
parentf02fed728f7bf1d88a8acd80a12b77fcf5ee5326 (diff)
downloadaur-d8ec3905565c992833c763281c5db127fcf1e869.tar.gz
Update to latest revision.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a60f1d2a2524..58eae90edcba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Dec 19 00:55:31 UTC 2015
+# Mon Apr 4 21:55:08 UTC 2016
pkgbase = pure
pkgdesc = Pure is a modern-style functional programming language based on term rewriting.
pkgver = 0.64
- pkgrel = 3
+ pkgrel = 4
url = http://purelang.bitbucket.org/
arch = i686
arch = x86_64
@@ -11,7 +11,8 @@ pkgbase = pure
groups = pure-base
license = GPL3
license = LGPL3
- depends = llvm35
+ makedepends = llvm35
+ depends = llvm35-libs
depends = gmp
depends = mpfr
depends = readline
diff --git a/PKGBUILD b/PKGBUILD
index 7cf5a31b6da5..c74eb0fa56a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,13 @@
pkgname=pure
pkgver=0.64
-pkgrel=3
+pkgrel=4
pkgdesc="Pure is a modern-style functional programming language based on term rewriting."
arch=("i686" "x86_64")
license=('GPL3' 'LGPL3')
url="http://purelang.bitbucket.org/"
-depends=('llvm35' 'gmp' 'mpfr' 'readline')
+depends=('llvm35-libs' 'gmp' 'mpfr' 'readline')
+makedepends=('llvm35')
optdepends=("pure-docs: online documentation"
"pcre: Perl regex support"
"w3m: access to help in interactive mode"
@@ -35,4 +36,7 @@ build() {
package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir install || return 1
+ # Copy the needed binaries from the LLVM toolchain to make the batch
+ # compiler work without having the llvm35 package installed.
+ cp /usr/bin/llc /usr/bin/llvm-as /usr/bin/opt $pkgdir/usr/lib/pure
}