summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:56:44 +0200
committerAlbert Graef2015-06-13 22:56:44 +0200
commit67a744479988f024154b44f865823f8b0319945a (patch)
tree0af153a1be97cd1042cf11600782d1b8ea44d6db
downloadaur-67a744479988f024154b44f865823f8b0319945a.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ff6b76999ff6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = pure-ffi
+ pkgdesc = An interface to libffi which enables you to call C functions from Pure and vice versa.
+ pkgver = 0.14
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-util
+ license = LGPL3
+ depends = pure
+ depends = libffi
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-ffi-0.14.tar.gz
+ sha1sums = 65a217e7950ac38f8633bb9bbb58903c541bfa29
+
+pkgname = pure-ffi
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff6b76999ff6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pure-ffi
+ pkgdesc = An interface to libffi which enables you to call C functions from Pure and vice versa.
+ pkgver = 0.14
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-util
+ license = LGPL3
+ depends = pure
+ depends = libffi
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-ffi-0.14.tar.gz
+ sha1sums = 65a217e7950ac38f8633bb9bbb58903c541bfa29
+
+pkgname = pure-ffi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dcf0a63bca5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alastair Pharo <asppsa at gmail dot com>
+
+pkgname=pure-ffi
+pkgver=0.14
+pkgrel=1
+pkgdesc="An interface to libffi which enables you to call C functions from Pure and vice versa."
+arch=("i686" "x86_64")
+license=('LGPL3')
+url="http://purelang.bitbucket.org/"
+depends=('pure' 'libffi')
+makedepends=()
+groups=(pure-complete pure-util)
+source=("https://bitbucket.org/purelang/pure-lang/downloads/$pkgname-$pkgver.tar.gz")
+sha1sums=('65a217e7950ac38f8633bb9bbb58903c541bfa29')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export C_INCLUDE_PATH=`pacman -Ql libffi | awk '/.*\/include\/.*/ {print $2}' | head -1` && make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install || return 1
+}