summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2019-03-26 00:32:21 +0100
committermrxx2019-03-26 00:32:21 +0100
commit0d228e4860b9c62267f62e97f28520490f55b60d (patch)
tree8a7141e48a3e5d313bd4cf66a2ccab976600c488
parentba071814e7f9b4bf8b14dfd4f09b34de6107babc (diff)
downloadaur-0d228e4860b9c62267f62e97f28520490f55b60d.tar.gz
Update to v1.0.48
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--tls1_3.patch43
3 files changed, 7 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e7ece3106b8..b92d87190fd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pure-ftpd
pkgdesc = A secure, production-quality and standard-conformant FTP server, focused on efficiency and ease of use.
- pkgver = 1.0.47
- pkgrel = 3
+ pkgver = 1.0.48
+ pkgrel = 1
url = https://www.pureftpd.org/
install = pure-ftpd.install
arch = i686
@@ -11,17 +11,15 @@ pkgbase = pure-ftpd
depends = mariadb-libs
conflicts = pure-ftpd-db
backup = etc/pure-ftpd/pure-ftpd.conf
- source = https://download.pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-1.0.47.tar.bz2
+ source = https://download.pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-1.0.48.tar.bz2
source = pure-ftpd.service
source = pure-ftpd.logrotate
source = welcome.msg
- source = tls1_3.patch
source = pure-ftpd.install
- md5sums = a41fa531c0d21bd3416dd524d75495ae
+ md5sums = 4538d563fb4cbe755767c91b14ed2fd2
md5sums = 0d0845e17607ffb212eae0112c58e9ff
md5sums = 37a45c88a0f038de37b4a87c6c447534
md5sums = 7e91835f7e7975bd0536648fc99e5a22
- md5sums = 85799b3cce0ca37b035269fef6939c2b
md5sums = c80cbd3ae1f9915f686f84149f6293e5
pkgname = pure-ftpd
diff --git a/PKGBUILD b/PKGBUILD
index e5f30d2d9096..a008b36978f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=pure-ftpd
-pkgver=1.0.47
-pkgrel=3
+pkgver=1.0.48
+pkgrel=1
pkgdesc="A secure, production-quality and standard-conformant FTP server, focused on efficiency and ease of use."
arch=('i686' 'x86_64')
url="https://www.pureftpd.org/"
@@ -22,21 +22,14 @@ source=("https://download.pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-${pkgver
'pure-ftpd.service'
'pure-ftpd.logrotate'
'welcome.msg'
- 'tls1_3.patch'
'pure-ftpd.install' )
-md5sums=('a41fa531c0d21bd3416dd524d75495ae'
+md5sums=('4538d563fb4cbe755767c91b14ed2fd2'
'0d0845e17607ffb212eae0112c58e9ff'
'37a45c88a0f038de37b4a87c6c447534'
'7e91835f7e7975bd0536648fc99e5a22'
- '85799b3cce0ca37b035269fef6939c2b'
'c80cbd3ae1f9915f686f84149f6293e5')
-prepare() {
- cd $pkgname-$pkgver
- patch -Np0 -i "${srcdir}/tls1_3.patch"
-}
-
build() {
cd ${srcdir}/${pkgname}-${pkgver}
./configure --prefix=/usr \
@@ -52,7 +45,6 @@ build() {
--with-peruserlimits \
--with-tls \
--with-rfc2640
- sed -i 's/define MAX_DATA_SIZE (40/define MAX_DATA_SIZE (70/' src/ftpd.h
make
}
diff --git a/tls1_3.patch b/tls1_3.patch
deleted file mode 100644
index 8dc143175d72..000000000000
--- a/tls1_3.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/tls.c.orig 2019-01-27 16:51:46.453334095 +0100
-+++ src/tls.c 2019-01-27 16:50:38.150000769 +0100
-@@ -228,7 +228,16 @@
- if ((where & SSL_CB_HANDSHAKE_START) != 0) {
- if ((cnx == tls_cnx && tls_cnx_handshook != 0) ||
- (cnx == tls_data_cnx && tls_data_cnx_handshook != 0)) {
-- die(400, LOG_ERR, "TLS renegociation");
-+ const SSL_CIPHER *cipher;
-+ const char *cipher_version;
-+ if ((cipher = SSL_get_current_cipher(cnx)) == NULL ||
-+ (cipher_version = SSL_CIPHER_get_version(cipher)) == NULL) {
-+ die(400, LOG_ERR, "No cipher");
-+ }
-+ if (strcmp(cipher_version, "TLSv1.3") != 0) {
-+ die(400, LOG_ERR, "TLS renegociation");
-+ return;
-+ }
- }
- return;
- }
-@@ -264,10 +273,10 @@
- OpenSSL_add_all_algorithms();
- # else
- OPENSSL_init_ssl(OPENSSL_INIT_LOAD_SSL_STRINGS |
-- OPENSSL_INIT_LOAD_CRYPTO_STRINGS, NULL);
-+ OPENSSL_INIT_LOAD_CRYPTO_STRINGS, NULL);
- OPENSSL_init_crypto(OPENSSL_INIT_ADD_ALL_CIPHERS |
-- OPENSSL_INIT_ADD_ALL_DIGESTS |
-- OPENSSL_INIT_LOAD_CONFIG, NULL);
-+ OPENSSL_INIT_ADD_ALL_DIGESTS |
-+ OPENSSL_INIT_LOAD_CONFIG, NULL);
- # endif
- while (RAND_status() == 0) {
- rnd = zrand();
-@@ -288,7 +297,7 @@
- SSL_CTX_set_options(tls_ctx, SSL_OP_NO_TLSv1);
- # endif
- # ifdef SSL_OP_NO_TLSv1_1
-- SSL_CTX_clear_options(tls_ctx, SSL_OP_NO_TLSv1_1);
-+ SSL_CTX_set_options(tls_ctx, SSL_OP_NO_TLSv1_1);
- # endif
- # ifdef SSL_OP_NO_TLSv1_2
- SSL_CTX_clear_options(tls_ctx, SSL_OP_NO_TLSv1_2); \ No newline at end of file