summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImmae2014-02-23 22:56:44 +0100
committerIsmaël Bouya2015-06-10 21:48:56 +0200
commit95901d9bceea4b259402be3bcc1cc1a8ea8d384b (patch)
tree2f723eb9fc9744f8dca663241c6e2f9670577211
downloadaur-95901d9bceea4b259402be3bcc1cc1a8ea8d384b.tar.gz
pure-ftpd-db
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD64
-rw-r--r--pure-ftpd-db.changelog8
-rw-r--r--pure-ftpd.service11
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a63963634e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pure-ftpd-db
+ pkgdesc = A fast, production quality, standards-conformant FTP server. Compiled with mysql and pgsql.
+ pkgver = 1.0.36
+ pkgrel = 7
+ url = http://www.pureftpd.org/
+ changelog = pure-ftpd-db.changelog
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = openssl
+ depends = postgresql
+ depends = libmariadbclient
+ provides = pure-ftpd
+ conflicts = pure-ftpd
+ backup = etc/pure-ftpd/pure-ftpd.conf
+ source = ftp://pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-1.0.36.tar.bz2
+ source = pure-ftpd.service
+ md5sums = 7899c75c1fed7dbad0352eb31080e066
+ md5sums = b6989f475edef34f2810646cc73b7b9e
+
+pkgname = pure-ftpd-db
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81ec0c8d2c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Contributor: Immae <ismael.bouya@normalesup.org>
+# Contributor: fila pruda.com
+# Contributor: tuxce <tuxce.net@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: BlueRaven <blue@ravenconsulting.it>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+# Maintainer: Immae <ismael.bouya@normalesup.org>
+pkgname=pure-ftpd-db
+_srcname=pure-ftpd
+pkgver=1.0.36
+pkgrel=7
+pkgdesc="A fast, production quality, standards-conformant FTP server. Compiled with mysql and pgsql."
+arch=('i686' 'x86_64')
+url="http://www.pureftpd.org/"
+license=('custom')
+changelog="$pkgname.changelog"
+provides=('pure-ftpd')
+conflicts=('pure-ftpd')
+depends=('openssl' 'postgresql' 'libmariadbclient')
+backup=('etc/pure-ftpd/pure-ftpd.conf')
+source=("ftp://pureftpd.org/pub/${_srcname}/releases/${_srcname}-${pkgver}.tar.bz2"
+ 'pure-ftpd.service')
+
+
+
+build() {
+ cd ${srcdir}/${_srcname}-${pkgver}
+ ./configure --prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --with-puredb \
+ --with-ftpwho \
+ --with-altlog \
+ --with-tls \
+ --with-pgsql \
+ --with-mysql \
+ --with-quotas
+ make
+}
+
+package() {
+ cd ${srcdir}/${_srcname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ${srcdir}/pure-ftpd.service ${pkgdir}/usr/lib/systemd/system/pure-ftpd.service
+
+ install -Dm644 configuration-file/pure-ftpd.conf ${pkgdir}/etc/pure-ftpd/pure-ftpd.conf
+ sed -i 's|#PIDFile /var/run/pure-ftpd.pid|PIDFile /run/pure-ftpd.pid|' ${pkgdir}/etc/pure-ftpd/pure-ftpd.conf
+ sed -i 's|# /usr/sbin/pure-config.pl /usr/etc/pure-ftpd.conf|# /usr/bin/pure-config.pl /etc/pure-ftpd.conf|' ${pkgdir}/etc/pure-ftpd/pure-ftpd.conf
+ sed -i 's|/etc/pureftpd|/etc/pure-ftpd/pureftpd|' ${pkgdir}/etc/pure-ftpd/pure-ftpd.conf
+
+ install -Dm755 configuration-file/pure-config.pl ${pkgdir}/usr/bin/pure-config.pl
+
+ #install license
+ install -Dm644 COPYING ${pkgdir}/usr/share/licenses/${_srcname}/LICENSE
+
+ #install doc
+ install -d ${pkgdir}/usr/share/doc/${_srcname}/
+ install -Dm644 -t ${pkgdir}/usr/share/doc/${_srcname}/ README* pureftpd-*sql.conf
+
+}
+md5sums=('7899c75c1fed7dbad0352eb31080e066'
+ 'b6989f475edef34f2810646cc73b7b9e')
+
diff --git a/pure-ftpd-db.changelog b/pure-ftpd-db.changelog
new file mode 100644
index 000000000000..c6d537aa4759
--- /dev/null
+++ b/pure-ftpd-db.changelog
@@ -0,0 +1,8 @@
+2013-10-20 Added maintainer tag
+
+2013-10-13 Modified a preexisting package
+in https://aur.archlinux.org/packages/pure-ftpd/ :
+- Added postgresql
+- Moved configuration to /etc/pure-ftpd/
+- Removed obsolete /etc/rc.d/
+
diff --git a/pure-ftpd.service b/pure-ftpd.service
new file mode 100644
index 000000000000..20c53171769b
--- /dev/null
+++ b/pure-ftpd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Pure-FTPd FTP server
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/pure-ftpd.pid
+ExecStart=/usr/bin/pure-config.pl /etc/pure-ftpd/pure-ftpd.conf
+
+[Install]
+WantedBy=multi-user.target