summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:42 +0200
committerAlbert Graef2015-06-13 22:58:42 +0200
commitc57fcdd9038a0d584f90a464cf814d4986eb8e6c (patch)
tree353a131dc0f8ad0899b7cda4664c522585f02643
downloadaur-c57fcdd9038a0d584f90a464cf814d4986eb8e6c.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD45
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a2354adcb5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pure-hg
+ pkgdesc = Pure is a modern-style functional programming language based on term rewriting.
+ pkgver = 5592.c229999c496e
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = mercurial
+ depends = llvm35
+ depends = gmp
+ depends = mpfr
+ depends = readline
+ optdepends = pure-docs-hg: online documentation
+ optdepends = pcre: Perl regex support
+ optdepends = w3m: access to help in interactive mode
+ optdepends = emacs-pure-mode: editing Pure files from Emacs
+ optdepends = texmacs-pure: embedding Pure sessions in TeXmacs
+ provides = pure
+ conflicts = pure
+ source = hg+https://bitbucket.org/purelang/pure-lang
+ md5sums = SKIP
+
+pkgname = pure-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f2ea53f381e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# -*- shell-script -*-
+# Maintainer: Alastair Pharo asppsa at gmail dot com
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=pure-hg
+pkgver=5592.c229999c496e
+pkgrel=1
+pkgdesc="Pure is a modern-style functional programming language based on term rewriting."
+arch=("i686" "x86_64")
+license=('GPL3' 'LGPL3')
+url="http://purelang.bitbucket.org/"
+depends=('llvm35' 'gmp' 'mpfr' 'readline')
+makedepends=('mercurial')
+optdepends=("pure-docs-hg: online documentation"
+ "pcre: Perl regex support"
+ "w3m: access to help in interactive mode"
+ "emacs-pure-mode: editing Pure files from Emacs"
+ "texmacs-pure: embedding Pure sessions in TeXmacs")
+provides=('pure')
+conflicts=('pure')
+source=("hg+https://bitbucket.org/purelang/pure-lang")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/pure-lang
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd $srcdir/pure-lang/pure
+ autoreconf
+ # For Perl5 regex support, at present you still need to add --with-pcre
+ # below (and make sure that you have pcre installed). This may become the
+ # default in the future.
+ ./configure --enable-release --prefix=/usr --without-elisp --without-texmacs
+ make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "$srcdir/pure-lang/pure"
+ make DESTDIR=$pkgdir install || return 1
+}
+
+# vim:set ts=2 sw=2 et: