summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Reeder2022-02-10 21:23:02 -0700
committerColin Reeder2022-02-10 21:23:02 -0700
commitbed48acace74107bbf9c2c0a3885920049cc3c5a (patch)
tree5c52b9cf8746b2c460196c08f6e5ba0e5fb0c7f8
parentdc34b5805ea6fb21f304f3c5d5c071582b1a2b7a (diff)
downloadaur-bed48acace74107bbf9c2c0a3885920049cc3c5a.tar.gz
Add more package metadata
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41384d417235..342b30159011 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,11 @@
pkgbase = pure-maps
+ pkgdesc = An application for Linux to display vector and raster maps, places, routes, etc.
pkgver = 2.9.2
- pkgrel = 1
+ pkgrel = 2
+ url = https://rinigus.github.io/pure-maps/
arch = x86_64
arch = aarch64
+ license = GPL3
depends = s2geometry
depends = python3
depends = qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index a6cb8676e8a0..074fc0951cff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,15 @@
+# Maintainer: Colin Reeder <colin@vpzom.click>
+
pkgname=pure-maps
+pkgdesc="An application for Linux to display vector and raster maps, places, routes, etc."
pkgver=2.9.2
-pkgrel=1
+pkgrel=2
arch=("x86_64" "aarch64")
source=("https://github.com/rinigus/pure-maps/archive/refs/tags/$pkgver.tar.gz")
sha256sums=('789dd7fdb865bd795e8695623a9c3dcbb0e22566614f0491069571fc211d7b89')
depends=("s2geometry" "python3" "qt5-base" "qt5-location" "qt5-declarative" "qt5-quickcontrols2" "nemo-qml-plugin-dbus" "python-pyotherside" "mapbox-gl-qml" "qt5-sensors" "python-gpxpy" "python-geomag")
+url="https://rinigus.github.io/pure-maps/"
+license=("GPL3")
build() {
cmake -B build -S "$pkgname-${pkgver}" \