summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-06-30 22:21:43 +0200
committerAlbert Graef2016-06-30 22:21:43 +0200
commit663646a9fc80ffbd740f274640b1d7797f1c8dbc (patch)
tree7c6fb16540a486672e5e90d1be61b58d7baa11fc
downloadaur-663646a9fc80ffbd740f274640b1d7797f1c8dbc.tar.gz
Initial upload.
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD46
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f2e4361f8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Thu Jun 30 20:19:12 UTC 2016
+pkgbase = pure-pcre-git
+ pkgdesc = Pure is a modern-style functional programming language based on term rewriting (variant with Perl regex support).
+ pkgver = r5645.f9f254d
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = mercurial
+ makedepends = llvm35
+ depends = llvm35-libs
+ depends = gmp
+ depends = mpfr
+ depends = pcre
+ depends = readline
+ optdepends = clang35: needed for inlining C/C++ code
+ optdepends = pure-docs-git: online documentation
+ optdepends = w3m: access to help in interactive mode
+ optdepends = emacs-pure-mode: editing Pure files from Emacs
+ optdepends = texmacs-pure: embedding Pure sessions in TeXmacs
+ provides = pure
+ provides = pure-git
+ conflicts = pure
+ conflicts = pure-git
+ replaces = pure-pcre-hg
+ source = git+https://bitbucket.org/purelang/pure-lang
+ md5sums = SKIP
+
+pkgname = pure-pcre-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55aa8c5bc96b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# -*- shell-script -*-
+# Maintainer: Alastair Pharo asppsa at gmail dot com
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=pure-pcre-git
+pkgver=r5645.f9f254d
+pkgrel=1
+pkgdesc="Pure is a modern-style functional programming language based on term rewriting (variant with Perl regex support)."
+arch=("i686" "x86_64")
+license=('GPL3' 'LGPL3')
+url="http://purelang.bitbucket.org/"
+depends=('llvm35-libs' 'gmp' 'mpfr' 'pcre' 'readline')
+makedepends=('mercurial' 'llvm35')
+optdepends=("clang35: needed for inlining C/C++ code"
+ "pure-docs-git: online documentation"
+ "w3m: access to help in interactive mode"
+ "emacs-pure-mode: editing Pure files from Emacs"
+ "texmacs-pure: embedding Pure sessions in TeXmacs")
+provides=('pure' 'pure-git')
+conflicts=('pure' 'pure-git')
+replaces=('pure-pcre-hg')
+source=("git+https://bitbucket.org/purelang/pure-lang")
+md5sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/pure-lang
+ echo r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd $srcdir/pure-lang/pure
+ autoreconf
+ ./configure --enable-release --prefix=/usr --without-elisp --without-texmacs --with-pcre
+ make || return 1
+ make check || return 1
+}
+
+package() {
+ cd "$srcdir/pure-lang/pure"
+ make DESTDIR=$pkgdir install || return 1
+ # Copy the needed binaries from the LLVM toolchain to make the batch
+ # compiler work without having the llvm35 package installed.
+ cp /usr/bin/llc /usr/bin/llvm-as /usr/bin/opt $pkgdir/usr/lib/pure
+}
+
+# vim:set ts=2 sw=2 et: