summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:57:55 +0200
committerAlbert Graef2015-06-13 22:57:55 +0200
commit7fb58893a8f7d3fdc25008bea5ad96868340622f (patch)
tree1e107680a2be42fae723a08672ccdc2cae43c147
downloadaur-7fb58893a8f7d3fdc25008bea5ad96868340622f.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
3 files changed, 64 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..4fce20d18e3d
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = pure-stldict
+ pkgdesc = This package provides a light-weight, no frills interface to the C++ dictionary containers map and unordered_map.
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-util
+ license = LGPL3
+ depends = pure
+ depends = libstdc++5
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-stldict-0.8.tar.gz
+ sha1sums = d2666346eac3410bc2839cdd920167ebedd72e21
+
+pkgname = pure-stldict
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fce20d18e3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pure-stldict
+ pkgdesc = This package provides a light-weight, no frills interface to the C++ dictionary containers map and unordered_map.
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://purelang.bitbucket.org/
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-util
+ license = LGPL3
+ depends = pure
+ depends = libstdc++5
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-stldict-0.8.tar.gz
+ sha1sums = d2666346eac3410bc2839cdd920167ebedd72e21
+
+pkgname = pure-stldict
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5a12ca3fac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: alastair pharo asppsa at gmail dot com
+# Contributor: Bjoern Lindig bjoern dot lindig at googlemail dot com
+
+pkgname=pure-stldict
+pkgver=0.8
+pkgrel=1
+pkgdesc="This package provides a light-weight, no frills interface to the C++ dictionary containers map and unordered_map."
+arch=("i686" "x86_64")
+license=('LGPL3')
+url="http://purelang.bitbucket.org/"
+depends=('pure' 'libstdc++5')
+makedepends=()
+groups=(pure-complete pure-util)
+source=("https://bitbucket.org/purelang/pure-lang/downloads/$pkgname-$pkgver.tar.gz")
+sha1sums=('d2666346eac3410bc2839cdd920167ebedd72e21')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ #./configure --prefix=/usr
+ #export LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
+
+ #make | tee - make.log || return 1
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ #make DESTDIR=$pkgdir install | tee - make_install.log || return 1
+ make DESTDIR=$pkgdir install || return 1
+}