summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2018-05-03 22:23:12 +0200
committerGFdevelop2018-05-03 22:23:12 +0200
commitb16d0ee5437eac5d7623d25c58cbef14022f36f1 (patch)
treea6c9f59cb8806c36a4d0808d0870d0a005c80502
downloadaur-b16d0ee5437eac5d7623d25c58cbef14022f36f1.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a814f4fcdad1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = purelibc-git
+ pkgdesc = A glibc overlay library for process self-virtualization
+ pkgver = r2.090b90d
+ pkgrel = 1
+ url = https://github.com/virtualsquare/purelibc
+ arch = any
+ groups = view-os
+ license = GPL2
+ provides = purelibc
+ conflicts = purelibc
+ replaces = purelibc
+ source = git+https://github.com/virtualsquare/purelibc.git
+ md5sums = SKIP
+
+pkgname = purelibc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2bd7596900a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="purelibc"
+
+pkgname="$_pkgname-git"
+pkgver=r2.090b90d
+pkgrel=1
+pkgdesc="A glibc overlay library for process self-virtualization"
+arch=('any')
+url="https://github.com/virtualsquare/$_pkgname"
+license=('GPL2')
+groups=('view-os')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+replaces=("$_pkgname")
+source=("git+https://github.com/virtualsquare/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}