summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrbavaCigla2019-10-05 12:16:18 +0200
committerGrbavaCigla2019-10-05 12:16:18 +0200
commit0070e5ed8a1b1e272c1d4a92f68a954a2927ab38 (patch)
tree7088232ed23018539b02649980b7325f53881ba0
downloadaur-0070e5ed8a1b1e272c1d4a92f68a954a2927ab38.tar.gz
Initializing pureref AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rw-r--r--pureref.install11
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..380b839abfec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pureref
+ pkgdesc = Reference Image Viewer. A simple and lightweight reference image viewer whose purpose is to display images without any distractions such as buttons or frames, while still providing the most common image transformation tools.
+ pkgver = 1.9.2
+ pkgrel = 1
+ url = http://www.pureref.com
+ install = pureref.install
+ arch = x86_64
+ makedepends = curl
+ options = !strip
+ options = !emptydirs
+ source = pureref-1.9.2.deb::https://www.pureref.com/files/installer.php?build=UNIX64.deb&downloadKey=BLZOr4abAghr5HxTbOtsVg%3D%3D
+ sha512sums = 225c94dd06841222e6cef0806056b38a7f6ba2f29a719f5a886230cd51bcf227dd43a90f1e7d7c8da81327ef76f038364cf05c65edc0e1e57d132e4a7baa0a6d
+
+pkgname = pureref
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80eef7217ec8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: GrbavaCigla <alexa.ognjanovic at gmail dot com>
+# Contributor: GrbavaCigla <alexa.ognjanovic at gmail dot com>
+# Contributor: hawerner
+pkgname=pureref
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Reference Image Viewer. A simple and lightweight reference image viewer whose purpose is to display images without any distractions such as buttons or frames, while still providing the most common image transformation tools."
+arch=('x86_64')
+url="http://www.pureref.com"
+license=('')
+makedepends=('curl')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source=("${pkgname}-${pkgver}.deb::https://www.pureref.com/files/installer.php?build=UNIX64.deb&downloadKey=$(curl https://www.pureref.com/download.php 2>/dev/null | grep var\ key | cut -d "\"" -f2 | cut -d "\"" -f1)")
+sha512sums=('225c94dd06841222e6cef0806056b38a7f6ba2f29a719f5a886230cd51bcf227dd43a90f1e7d7c8da81327ef76f038364cf05c65edc0e1e57d132e4a7baa0a6d')
+
+package(){
+ cd $srcdir
+ ar x "${pkgname}-${pkgver}.deb"
+ tar xf data.tar.xz -C "${pkgdir}"
+}
diff --git a/pureref.install b/pureref.install
new file mode 100644
index 000000000000..d83e4a65d5a2
--- /dev/null
+++ b/pureref.install
@@ -0,0 +1,11 @@
+post_install() {
+ sudo xdg-mime install --mode system --novendor /usr/share/mime/application/pureref.xml
+ sudo xdg-icon-resource install --context mimetypes --size 48 /usr/share/icons/hicolor/48x48/apps/pureref-file-icon.png application-pureref
+ sudo xdg-icon-resource install --context mimetypes --size 128 /usr/share/icons/hicolor/128x128/apps/pureref-file-icon.png application-pureref
+ sudo xdg-mime default PureRef.desktop application/pureref
+ sudo update-mime-database /usr/share/mime
+}
+
+post_upgrade() {
+ post_install
+}