summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Ruffwind2017-08-27 16:57:45 -0400
committerPhil Ruffwind2017-08-27 16:57:45 -0400
commit2a35349f4df92d89651b78f80ab1ed69c1b23e43 (patch)
tree4b46f70fbebe094bbf79b87740bfbf83f69117cc
parent2705bea572df48411e1b3f995658908cc0231045 (diff)
downloadaur-2a35349f4df92d89651b78f80ab1ed69c1b23e43.tar.gz
0.11.6
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 26 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b1d586bf190..1fc944a677ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Mon Jun 6 02:08:41 UTC 2016
+# Sun Aug 27 20:57:46 UTC 2017
pkgbase = purescript-bin
- pkgdesc = A small strongly typed programming language with expressive types that compiles to Javascript, written in and inspired by Haskell.
- pkgver = 0.9.1
+ pkgdesc = A strongly-typed functional programming language that compiles to JavaScript
+ pkgver = 0.11.6
pkgrel = 1
- url = http://www.purescript.org/
+ url = http://www.purescript.org
arch = x86_64
- license = MIT
- makedepends = chrpath
+ license = BSD
depends = gmp
- depends = libtinfo5
+ depends = ncurses5-compat-libs
depends = zlib
provides = purescript
- conflicts = purescript-stack
- source = purescript-0.9.1.tar.gz::https://github.com/purescript/purescript/releases/download/v0.9.1/linux64.tar.gz
- sha1sums = 9e8ff98e1e5d0dbf34df5124dc42d3b73e9dc257
+ conflicts = purescript
+ source = https://github.com/purescript/purescript/releases/download/v0.11.6/linux64.tar.gz
+ sha1sums = 3eb742521db7d87359346143a47230b73110ccbe
pkgname = purescript-bin
diff --git a/PKGBUILD b/PKGBUILD
index bac00562c031..9f46e070e8ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
-# Maintainer: Jonas Platte <aur@jonasplatte.de>
-
+# Maintainer: Phil Ruffwind <rf@rufflewind.com>
+# Contributor: Jonas Platte <aur@jonasplatte.de>
pkgname=purescript-bin
-pkgver=0.9.1
+pkgver=0.11.6
pkgrel=1
-pkgdesc="A small strongly typed programming language with expressive types that compiles to Javascript, written in and inspired by Haskell."
-arch=('x86_64')
-url="http://www.purescript.org/"
-license=('MIT')
-depends=('gmp' 'libtinfo5' 'zlib')
-makedepends=('chrpath')
-provides=('purescript')
-conflicts=('purescript-stack')
-source=("purescript-${pkgver}.tar.gz::https://github.com/purescript/purescript/releases/download/v${pkgver}/linux64.tar.gz")
-sha1sums=('9e8ff98e1e5d0dbf34df5124dc42d3b73e9dc257')
-
-# An array doesn't seem to work with makepkg for some reason, but
-# chrpath and install both support specifying multiple files at once
-_binaries="psc psci psc-bundle psc-docs psc-ide-client psc-ide-server psc-publish"
+pkgdesc="A strongly-typed functional programming language that compiles to JavaScript"
+arch=(x86_64)
+url=http://www.purescript.org
+license=(BSD)
+depends=(gmp ncurses5-compat-libs zlib)
+provides=(purescript)
+conflicts=(purescript)
+source=(https://github.com/purescript/purescript/releases/download/v$pkgver/linux64.tar.gz)
+sha1sums=('3eb742521db7d87359346143a47230b73110ccbe')
package() {
- cd purescript
-
- install -t "${pkgdir}/usr/bin" -D -m755 $_binaries
- chrpath -d "${pkgdir}/usr/bin"/*
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$srcdir/purescript/$f"
+ find . -type f -perm -a=x -print0 | while read -r -d '' f; do
+ install -Dm755 "$f" "$pkgdir/usr/bin/$f"
+ done
+ install -Dm644 "$srcdir/purescript/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}