summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoneshf2015-06-07 19:41:03 -0700
committerjoneshf2015-06-30 07:01:52 -0700
commita2f8ed825d6389c3f1f8185afe4bf87e0db36b41 (patch)
treeea08f0701db4b65b659e3ec160ea41fe0dc94828
parent035471fdcc6b24c24363af9644bfb95c39a2df6f (diff)
downloadaur-a2f8ed825d6389c3f1f8185afe4bf87e0db36b41.tar.gz
Updated version to 0.6.9.5.
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate_version.sh4
2 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6e26d4c7ea8..be6a0c424c42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Hardy Jones <jones3 dot hardy at gmail dot com>
pkgname=purescript-bin
-pkgver=0.6.9.3
+pkgver=0.6.9.5
pkgrel=1
pkgdesc="A strongly, statically typed language compiling to JavaScript."
arch=('x86_64')
@@ -9,7 +9,7 @@ license=('MIT')
depends=('glibc' 'gmp' 'gcc-libs' 'libtinfo')
provides=('purescript')
source=("https://github.com/joneshf/purescript/releases/download/v$pkgver/linux64.tar.gz")
-sha512sums=('5b1c04cb1767b2b09eab207b2f43ed409f90b5d9cb69315e0ab68e97b20d6596683503d92219f148b4bd5534c5135871fae827adacbcc2d3c50563f28e13f7ff')
+sha512sums=('2f9e267cd171816a17affcf90c68c5bdec72ee4f12e9de521fb3ec30b1c3e92c6603e775282f2e29b31f31f4c3c3a32b8ae2f98e0fd504e1cea3b94cab56a9c7')
package() {
cd "${srcdir}"/purescript
diff --git a/update_version.sh b/update_version.sh
index e164b0eb6e2b..1fa77a1fc7ce 100755
--- a/update_version.sh
+++ b/update_version.sh
@@ -1,9 +1,9 @@
#!/bin/bash
set -e -v
+VERSION=$1
API_JSON=$(printf '{"tag_name": "v%s", "target_commitish": "master", "name": "v%s", "body": "v%s", "draft": false, "prerelease": false}' $VERSION $VERSION $VERSION)
RELEASE_URL=https://api.github.com/repos/joneshf/purescript/releases
-VERSION=$1
# Grab the original tar.
curl -L "https://github.com/purescript/purescript/releases/download/v$VERSION/linux64.tar.gz"> orig.tar.gz
@@ -11,6 +11,8 @@ curl -L "https://github.com/purescript/purescript/releases/download/v$VERSION/li
curl --data "$API_JSON" $RELEASE_URL?access_token=$PURESCRIPT_BIN_TOKEN
# Upload the tar.
ASSET_URL=$(curl "$RELEASE_URL/tags/v$VERSION?access_token=$PURESCRIPT_BIN_TOKEN" | json upload_url | sed "s/{.*//")
+echo $RELEASE_URL
+echo $ASSET_URL
curl -X POST -H "Content-Type:application/gzip" "$ASSET_URL?access_token=$PURESCRIPT_BIN_TOKEN&name=linux64.tar.gz" -T orig.tar.gz
# Continue with what we normally do.