summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin/Geno2018-12-12 22:52:15 +0100
committerMartin/Geno2018-12-12 22:52:15 +0100
commit090f237306adda6740aa6c17c99c3299e7175ed3 (patch)
treea406d12276fc0b2b94f187ee6fa772aeb6868bd6
downloadaur-090f237306adda6740aa6c17c99c3299e7175ed3.tar.gz
init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54c92751141d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = purism-chatty-git
+ pkgdesc = XMPP and SMS messaging via libpurple and Modemmanager
+ pkgver = 0.0.1.r13.gdaaa736
+ pkgrel = 1
+ url = https://source.puri.sm/Librem5/chatty
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = LGPL2.1
+ makedepends = pkg-config
+ makedepends = meson
+ makedepends = libhandy
+ depends = gtk3
+ provides = purism-chatty
+ conflicts = purism-chatty
+ source = git+https://source.puri.sm/Librem5/chatty.git
+ md5sums = SKIP
+
+pkgname = purism-chatty-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eea5b7347b94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: geno+dev@fireorbit.de
+
+pkgname=purism-chatty-git
+pkgver=0.0.1.r13.gdaaa736
+pkgrel=1
+pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
+url="https://source.puri.sm/Librem5/chatty"
+license=(LGPL2.1)
+arch=(i686 x86_64 armv6h armv7h)
+depends=(gtk3)
+makedepends=(pkg-config meson libhandy)
+provides=(purism-chatty)
+conflicts=(purism-chatty)
+source=("git+https://source.puri.sm/Librem5/chatty.git")
+md5sums=(SKIP)
+
+pkgver() {
+ git -C chatty describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ rm -rf build
+ arch-meson chatty build -Dexamples=false -Dgtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}