summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlafleur2021-12-12 16:26:56 +0100
committerlafleur2021-12-12 16:28:29 +0100
commit359ae3733a88d4eb1e5e23120ae8a2cc872a9b47 (patch)
treea818fd8a2d97fe5589abce0e5be42898104abf20
parentb81ddfe31c63672aa5f088a5db9d9c36ba8b96d1 (diff)
downloadaur-359ae3733a88d4eb1e5e23120ae8a2cc872a9b47.tar.gz
patch sources to use libolm-3.2.7
-rw-r--r--PKGBUILD11
-rw-r--r--latest_olm.patch12
2 files changed, 21 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0800f75b91b1..3c8c870ec988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,6 @@ pkgver=0.5.0_beta3.r1.g73caf3d
pkgrel=1
pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
url="https://source.puri.sm/Librem5/chatty"
-source=("git+https://source.puri.sm/Librem5/chatty.git")
-md5sums=(SKIP)
license=("LGPL2.1")
arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
depends=("evolution-data-server"
@@ -29,11 +27,20 @@ provides=("purism-chatty")
conflicts=("purism-chatty")
# Keep the source in a version-independent directory, so on update we simply
# git pull into it.
+source=(
+ "${_pkgname}::git+https://source.puri.sm/Librem5/chatty.git"
+ "latest_olm.patch"
+)
+md5sums=(SKIP c934d64deacfdec2592cea05d1a7f8cc)
pkgver() {
git -C ${_pkgname} describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch --directory=${_pkgname} --forward --strip=1 --input=${srcdir}/latest_olm.patch
+}
+
build() {
# Only setup the build directory if it doesn't exist :
test -d build || arch-meson ${_pkgname} build
diff --git a/latest_olm.patch b/latest_olm.patch
new file mode 100644
index 000000000000..53af14676e86
--- /dev/null
+++ b/latest_olm.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text purism-chatty.orig/sm.puri.Chatty.json purism-chatty.new/sm.puri.Chatty.json
+--- purism-chatty.orig/sm.puri.Chatty.json 2021-12-12 15:56:30.110497868 +0100
++++ purism-chatty.new/sm.puri.Chatty.json 2021-12-12 15:59:49.744909048 +0100
+@@ -224,7 +224,7 @@
+ "sources": [
+ {
+ "type": "git",
+- "tag" : "3.2.6",
++ "tag" : "3.2.7",
+ "url": "https://gitlab.matrix.org/matrix-org/olm.git"
+ }
+ ]