summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlafleur2021-12-12 16:26:33 +0100
committerlafleur2021-12-12 16:26:33 +0100
commitb81ddfe31c63672aa5f088a5db9d9c36ba8b96d1 (patch)
tree62c31fad96b5da0d12fd7364a4e49cce5c4ad79b
parent5cc8bf8bb2b8b36cd518f47d76bc2755775ec0dd (diff)
downloadaur-b81ddfe31c63672aa5f088a5db9d9c36ba8b96d1.tar.gz
update to chatty 0.5.0
-rw-r--r--PKGBUILD41
1 files changed, 25 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74b14e903f52..0800f75b91b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,42 @@
# Maintainer: genofire <geno+dev@fireorbit.de>
+# Contributor: la Fleur <lafleur at boum dot org>
_pkgname="purism-chatty"
pkgname="${_pkgname}-git" # '-bzr', '-git', '-hg' or '-svn'
-pkgver=0.2.0.r102.g71c0c83
+pkgver=0.5.0_beta3.r1.g73caf3d
pkgrel=1
pkgdesc="XMPP and SMS messaging via libpurple and Modemmanager"
url="https://source.puri.sm/Librem5/chatty"
-license=('LGPL2.1')
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
-depends=('libhandy' 'libpurple' 'evolution-data-server' 'feedbackd')
-optdepends=('libpurple-lurch: XMPP E2E OMEMO encryption'
- 'libpurple-carbons: XMPP Carbon Copy - Live multiple device support'
- 'purple-xmpp-http-upload: XMPP HTTP Upload - Filesharing'
- 'purple-mm-sms: SMS plugin using ModemManager'
- 'purple-matrix: Matrix support'
- 'libolm: add OLM for Matrix encryption')
-makedepends=('pkg-config' 'meson' 'libolm')
-provides=('purism-chatty')
-conflicts=('purism-chatty')
source=("git+https://source.puri.sm/Librem5/chatty.git")
md5sums=(SKIP)
+license=("LGPL2.1")
+arch=("i686" "x86_64" "armv6h" "armv7h" "aarch64")
+depends=("evolution-data-server"
+ "feedbackd"
+ "gtk4"
+ "libhandy"
+ "libpurple"
+ "gspell"
+ "libmm-glib")
+optdepends=("feedbackd: haptic, visual and audio feedback"
+ "libpurple-carbons: XMPP Carbon Copy - Live multiple device support"
+ "libpurple-lurch: message encryption when using OMEMO"
+ "mmsd-tng: support MMS send/receive"
+ "purple-telegram: Telegram support"
+ "purple-matrix: Matrix support")
+makedepends=("git" "pkg-config" "meson" "libolm")
+provides=("purism-chatty")
+conflicts=("purism-chatty")
+# Keep the source in a version-independent directory, so on update we simply
+# git pull into it.
pkgver() {
- git -C chatty describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C ${_pkgname} describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- rm -rf build
- arch-meson chatty build -Dexamples=false -Dgtk_doc=true
+ # Only setup the build directory if it doesn't exist :
+ test -d build || arch-meson ${_pkgname} build
ninja -C build
}