summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorubba2019-03-06 23:00:28 +0100
committercorubba2019-03-06 23:08:51 +0100
commitec5759396376ab888bc69a7bf20270b350c45e0a (patch)
tree0fbe52df9a8b8febbf621688595a3f613d4b1a53
downloadaur-purple-icyque-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..465952a66678
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = purple-icyque-git
+ pkgdesc = A libpurple/Pidgin plugin for ICQ WIM protocol
+ pkgver = r26.c0187fe
+ pkgrel = 1
+ url = https://github.com/EionRobb/icyque
+ arch = any
+ license = GPL
+ makedepends = json-glib
+ depends = libpurple
+ source = icyque::git+https://github.com/EionRobb/icyque.git
+ md5sums = SKIP
+
+pkgname = purple-icyque-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5273443900d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+icyque/
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66e696043de0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: corubba <corubba at gmx dot de>
+pkgname=purple-icyque-git
+pkgver=r26.c0187fe
+pkgrel=1
+pkgdesc="A libpurple/Pidgin plugin for ICQ WIM protocol"
+arch=('any')
+url="https://github.com/EionRobb/icyque"
+license=('GPL')
+depends=('libpurple')
+makedepends=('json-glib')
+source=('icyque::git+https://github.com/EionRobb/icyque.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "icyque"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "icyque"
+ make
+}
+
+package() {
+ cd "icyque"
+ make DESTDIR="${pkgdir}/" install
+}