summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2018-01-03 11:33:22 +0100
committerAlbert Graef2018-01-03 11:33:22 +0100
commit07d5969a400127ba445b1b8ce7306f156d977e57 (patch)
treeb6641faee51765887e8082b6f1b88fb8dfeb49b1
parent650566d748bf6df63073f245bcad93bc5c408449 (diff)
downloadaur-07d5969a400127ba445b1b8ce7306f156d977e57.tar.gz
Fix up ImageMagick dependency (Gem needs libmagick6).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--gem-magick6-fixes.patch15
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ea8a1730350..8fb510b4477a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 05:12:00 UTC 2017
+# Wed Jan 3 10:32:25 UTC 2018
pkgbase = purr-data
pkgdesc = Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
- pkgver = 2.4.6.r3761.46ffba37
+ pkgver = 2.4.6.r3766.4af8d07b
pkgrel = 1
url = https://git.purrdata.net/jwilkes/purr-data
install = purr-data.install
@@ -27,7 +27,7 @@ pkgbase = purr-data
depends = gsl
depends = gsm
depends = hicolor-icon-theme
- depends = imagemagick
+ depends = libmagick6
depends = jack
depends = ladspa
depends = lame
@@ -62,8 +62,10 @@ pkgbase = purr-data
options = !strip
source = purr-data::git+https://git.purrdata.net/aggraef/purr-data.git#branch=release
source = RTcmix-pd-LCPLAY-stabilize.patch
+ source = gem-magick6-fixes.patch
md5sums = SKIP
md5sums = 39c53063dc18681f29b12c08d9c453aa
+ md5sums = 63c6794adbc47e4c239eeb50ed30bfa8
source_i686 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-ia32.tar.gz
md5sums_i686 = e4708d59006219eaa2c54cdb1d682794
source_x86_64 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-x64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index e0218cb1a235..f6b7e546d41b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@
# /usr/lib/purr-data, so that 3rd party externals know where to find these.
pkgname=purr-data
-pkgver=2.4.6.r3761.46ffba37
+pkgver=2.4.6.r3766.4af8d07b
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
@@ -38,7 +38,7 @@ arch=('i686' 'x86_64')
license=('BSD')
depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'flite1' 'fluidsynth' 'freeglut' 'ftgl' 'glew' 'gmerlin'
- 'gsl' 'gsm' 'hicolor-icon-theme' 'imagemagick' 'jack' 'ladspa' 'lame'
+ 'gsl' 'gsm' 'hicolor-icon-theme' 'libmagick6' 'jack' 'ladspa' 'lame'
'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
'libxxf86vm' 'libtiff' 'libiec61883' 'libunicap' 'libraw1394'
'libsndobj-git' 'libv4l' 'libvorbis' 'portaudio'
@@ -58,9 +58,11 @@ options=('!makeflags' '!strip')
# deal with situations where upstream lags behind on already submitted merge
# requests with important bugfixes and additions.
source=("$pkgname::git+https://git.purrdata.net/aggraef/purr-data.git#branch=release"
- "RTcmix-pd-LCPLAY-stabilize.patch")
+ "RTcmix-pd-LCPLAY-stabilize.patch"
+ "gem-magick6-fixes.patch")
md5sums=('SKIP'
- '39c53063dc18681f29b12c08d9c453aa')
+ '39c53063dc18681f29b12c08d9c453aa'
+ '63c6794adbc47e4c239eeb50ed30bfa8')
# nw.js sdk binaries
nwjsname=nwjs-sdk
nwjsver=0.22.1
@@ -106,6 +108,8 @@ prepare() {
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
# make the sources compile with gcc 6.1+
cd $srcdir/$pkgname/externals/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
+ # make sure to link Gem with ImageMagick 6, it doesn't compile with 7
+ cd $srcdir/$pkgname && patch -Np1 < $srcdir/gem-magick6-fixes.patch
}
build() {
diff --git a/gem-magick6-fixes.patch b/gem-magick6-fixes.patch
new file mode 100644
index 000000000000..6f1eb8abe5f1
--- /dev/null
+++ b/gem-magick6-fixes.patch
@@ -0,0 +1,15 @@
+diff --git a/externals/Makefile b/externals/Makefile
+index e60a73c9..09066109 100644
+--- a/externals/Makefile
++++ b/externals/Makefile
+@@ -658,6 +658,10 @@ $(gem_src)/Gem.pd_linux: $(gem_src)/configure
+ test -s $(gem_src)/Gem.pd_linux || \
+ cd $(gem_src) && ./configure \
+ CXXFLAGS="-DHAVE_S_STUFF_H" \
++ PKG_IMAGEMAGICK___CFLAGS="$(shell pkg-config --cflags ImageMagick-6.Q16HDRI)" \
++ PKG_IMAGEMAGICK___LIBS="$(shell pkg-config --libs ImageMagick-6.Q16HDRI)" \
++ PKG_MAGICKCORE_CFLAGS="$(shell pkg-config --cflags MagickCore-6.Q16HDRI)" \
++ PKG_MAGICKCORE_LIBS="$(shell pkg-config --libs MagickCore-6.Q16HDRI)" \
+ --prefix=$(prefix) \
+ --with-video=plugins \
+ --with-film=plugins \