summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2022-08-03 22:05:04 +0200
committerAlbert Graef2022-08-03 22:05:04 +0200
commit71010afa5d7578e67372bb8afecc9db76d11ffd4 (patch)
tree3b4ead70c9adbe7b739399964015dc0653f5944b
parent9798d86484bb0ccea6f9ce5e02eecd0d51483823 (diff)
downloadaur-71010afa5d7578e67372bb8afecc9db76d11ffd4.tar.gz
Update to latest upstream, remove libquicktime (it's not really needed).
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fbedc6f0042..806cfb69a71b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = purr-data-git
pkgdesc = Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
- pkgver = 2.12.0.r4366.6d94e10b
+ pkgver = 2.17.0.r4863.fa783023c
pkgrel = 1
url = https://git.purrdata.net/jwilkes/purr-data
install = purr-data.install
@@ -34,7 +34,6 @@ pkgbase = purr-data-git
depends = libgl
depends = libiec61883
depends = libjpeg
- depends = libquicktime
depends = libxxf86vm
depends = libtiff
depends = libiec61883
@@ -60,10 +59,9 @@ pkgbase = purr-data-git
options = !strip
source = purr-data-git::git+https://git.purrdata.net/jwilkes/purr-data.git
md5sums = SKIP
- source_i686 = http://dl.nwjs.io/v0.24.4/nwjs-sdk-v0.24.4-linux-ia32.tar.gz
- md5sums_i686 = a7afcd35d2891e7b7c78db5ca7a625a3
- source_x86_64 = http://dl.nwjs.io/v0.24.4/nwjs-sdk-v0.24.4-linux-x64.tar.gz
- md5sums_x86_64 = 82f20fe9081201db81652eb066c29f9b
+ source_i686 = http://dl.nwjs.io/v0.28.1/nwjs-sdk-v0.28.1-linux-ia32.tar.gz
+ md5sums_i686 = 6f2a2b0a58f50babbf3fb89163ca801f
+ source_x86_64 = http://dl.nwjs.io/v0.28.1/nwjs-sdk-v0.28.1-linux-x64.tar.gz
+ md5sums_x86_64 = 7557def0771c6fc9919aabde0a78730a
pkgname = purr-data-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2f39186f589e..76becf9fe37c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
# /usr/lib/purr-data, so that 3rd party externals know where to find these.
pkgname=purr-data-git
-pkgver=2.12.0.r4366.6d94e10b
+pkgver=2.17.0.r4863.fa783023c
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
@@ -27,7 +27,7 @@ license=('BSD')
depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'flite' 'fluidsynth' 'freeglut' 'ftgl' 'glew'
'gsl' 'gsm' 'hicolor-icon-theme' 'imagemagick' 'jack' 'ladspa' 'lame'
- 'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
+ 'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg'
'libxxf86vm' 'libtiff' 'libiec61883' 'libraw1394'
'libv4l' 'libvorbis' 'portaudio'
'smpeg' 'speex' 'stk' 'zlib' 'lua'
@@ -41,12 +41,12 @@ source=("$pkgname::git+https://git.purrdata.net/jwilkes/purr-data.git")
md5sums=('SKIP')
# nw.js sdk binaries
nwjsname=nwjs-sdk
-nwjsver=0.24.4
+nwjsver=0.28.1
source_common="http://dl.nwjs.io/v$nwjsver/$nwjsname-v$nwjsver-linux"
source_i686=("$source_common-ia32.tar.gz")
source_x86_64=("$source_common-x64.tar.gz")
-md5sums_i686=('a7afcd35d2891e7b7c78db5ca7a625a3')
-md5sums_x86_64=('82f20fe9081201db81652eb066c29f9b')
+md5sums_i686=('6f2a2b0a58f50babbf3fb89163ca801f')
+md5sums_x86_64=('7557def0771c6fc9919aabde0a78730a')
if [ "$CARCH" = "i686" ]; then
_arch="ia32"
@@ -75,9 +75,9 @@ prepare() {
cd $srcdir/$pkgname
# first make sure that we get any checked out submodules in pristine state
# again, so that our patches apply cleanly
- git submodule foreach git checkout .
+ make realclean
# check out the latest source of all submodules
- git submodule update --init
+ make checkout
# copy the nw.js sources to where purr-data wants them
rm -rf pd/nw/nw
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw