summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2018-01-03 11:14:51 +0100
committerAlbert Graef2018-01-03 11:14:51 +0100
commit7fb5aa88f7407f1423564404ccb4f151ec9ee9b7 (patch)
treee03875132b78779b2cee3760ac91f916d269514a
parent88cf6289b09f2d03b0235e6c665e9bdc6851d768 (diff)
downloadaur-7fb5aa88f7407f1423564404ccb4f151ec9ee9b7.tar.gz
Fix up ImageMagick dependency (Gem needs libmagick6).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--gem-magick6-fixes.patch15
3 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ecc5dc571a2..625907db3784 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 13 11:37:34 UTC 2017
+# Wed Jan 3 10:14:25 UTC 2018
pkgbase = purr-data-git
pkgdesc = Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
- pkgver = 2.4.5.r3756.981540a7
+ pkgver = 2.4.6.r3765.6b3ae079
pkgrel = 1
url = https://git.purrdata.net/jwilkes/purr-data
install = purr-data.install
@@ -27,7 +27,7 @@ pkgbase = purr-data-git
depends = gsl
depends = gsm
depends = hicolor-icon-theme
- depends = imagemagick
+ depends = libmagick6
depends = jack
depends = ladspa
depends = lame
@@ -63,8 +63,10 @@ pkgbase = purr-data-git
options = !strip
source = purr-data-git::git+https://git.purrdata.net/jwilkes/purr-data.git
source = RTcmix-pd-LCPLAY-stabilize.patch
+ source = gem-magick6-fixes.patch
md5sums = SKIP
md5sums = 39c53063dc18681f29b12c08d9c453aa
+ md5sums = 63c6794adbc47e4c239eeb50ed30bfa8
source_i686 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-ia32.tar.gz
md5sums_i686 = e4708d59006219eaa2c54cdb1d682794
source_x86_64 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-x64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 53441697108c..3d92f7ff3524 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,7 @@
# /usr/lib/purr-data, so that 3rd party externals know where to find these.
pkgname=purr-data-git
-pkgver=2.4.5.r3756.981540a7
+pkgver=2.4.6.r3765.6b3ae079
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
@@ -33,7 +33,7 @@ arch=('i686' 'x86_64')
license=('BSD')
depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
'flite1' 'fluidsynth' 'freeglut' 'ftgl' 'glew' 'gmerlin'
- 'gsl' 'gsm' 'hicolor-icon-theme' 'imagemagick' 'jack' 'ladspa' 'lame'
+ 'gsl' 'gsm' 'hicolor-icon-theme' 'libmagick6' 'jack' 'ladspa' 'lame'
'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
'libxxf86vm' 'libtiff' 'libiec61883' 'libunicap' 'libraw1394'
'libsndobj-git' 'libv4l' 'libvorbis' 'portaudio'
@@ -45,9 +45,11 @@ conflicts=('purr-data')
install=purr-data.install
options=('!makeflags' '!strip')
source=("$pkgname::git+https://git.purrdata.net/jwilkes/purr-data.git"
- "RTcmix-pd-LCPLAY-stabilize.patch")
+ "RTcmix-pd-LCPLAY-stabilize.patch"
+ "gem-magick6-fixes.patch")
md5sums=('SKIP'
- '39c53063dc18681f29b12c08d9c453aa')
+ '39c53063dc18681f29b12c08d9c453aa'
+ '63c6794adbc47e4c239eeb50ed30bfa8')
# nw.js sdk binaries
nwjsname=nwjs-sdk
nwjsver=0.22.1
@@ -93,6 +95,8 @@ prepare() {
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
# make the sources compile with gcc 6.1+
cd $srcdir/$pkgname/externals/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
+ # make sure to link Gem with ImageMagick 6, it doesn't compile with 7
+ cd $srcdir/$pkgname && patch -Np1 < $srcdir/gem-magick6-fixes.patch
}
build() {
@@ -116,8 +120,11 @@ package() {
mkdir -p "$pkgdir/usr/lib"
ln -sf $prefix/lib/pd-l2ork "$pkgdir/usr/lib/purr-data"
# Just remove all the /etc stuff and the Emacs mode for now, we don't really
- # need these.
+ # need most of these.
rm -rf "$pkgdir/etc" "$pkgdir/usr/share/emacs"
+ # Add the bash completion file again, and edit it accordingly.
+ mkdir -p "$pkgdir/etc/bash_completion.d"
+ sed -e 's/pd-l2ork/purr-data/g' < "$srcdir/$pkgname/scripts/bash_completion/pd-l2ork" > "$pkgdir/etc/bash_completion.d/purr-data"
# Edit the library paths in the default user.settings file so that it
# matches our install prefix.
cd "$pkgdir$prefix/lib/pd-l2ork"
@@ -146,8 +153,8 @@ package() {
cd "$pkgdir"
chmod -R go-w *
chmod -R a+r *
- chmod a-x opt/purr-data/lib/pd-l2ork/default.settings
- find opt/purr-data/lib/pd-l2ork/bin/nw -executable -not -type d -exec chmod a+x {} +
+ chmod a-x .$prefix/lib/pd-l2ork/default.settings
+ find .$prefix/lib/pd-l2ork/bin/nw -executable -not -type d -exec chmod a+x {} +
#find . -executable -name '*.pd_linux' -exec chmod a-x {} +
find . -executable -name '*.pd' -exec chmod a-x {} +
find . -executable -name '*.txt' -exec chmod a-x {} +
diff --git a/gem-magick6-fixes.patch b/gem-magick6-fixes.patch
new file mode 100644
index 000000000000..6f1eb8abe5f1
--- /dev/null
+++ b/gem-magick6-fixes.patch
@@ -0,0 +1,15 @@
+diff --git a/externals/Makefile b/externals/Makefile
+index e60a73c9..09066109 100644
+--- a/externals/Makefile
++++ b/externals/Makefile
+@@ -658,6 +658,10 @@ $(gem_src)/Gem.pd_linux: $(gem_src)/configure
+ test -s $(gem_src)/Gem.pd_linux || \
+ cd $(gem_src) && ./configure \
+ CXXFLAGS="-DHAVE_S_STUFF_H" \
++ PKG_IMAGEMAGICK___CFLAGS="$(shell pkg-config --cflags ImageMagick-6.Q16HDRI)" \
++ PKG_IMAGEMAGICK___LIBS="$(shell pkg-config --libs ImageMagick-6.Q16HDRI)" \
++ PKG_MAGICKCORE_CFLAGS="$(shell pkg-config --cflags MagickCore-6.Q16HDRI)" \
++ PKG_MAGICKCORE_LIBS="$(shell pkg-config --libs MagickCore-6.Q16HDRI)" \
+ --prefix=$(prefix) \
+ --with-video=plugins \
+ --with-film=plugins \