summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2018-04-04 19:08:38 +0200
committerAlbert Graef2018-04-04 19:08:38 +0200
commitbd7f60f8f838b2afedc3d5e7b60e3a70b624b776 (patch)
tree579cc30ac7d21f64d256b8699d4579e125286821
parent7fb5aa88f7407f1423564404ccb4f151ec9ee9b7 (diff)
downloadaur-bd7f60f8f838b2afedc3d5e7b60e3a70b624b776.tar.gz
Update to latest upstream, make Gem work again, change flite1 dependency to flite.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD43
-rw-r--r--RTcmix-pd-LCPLAY-stabilize.patch13
-rw-r--r--gem-magick6-fixes.patch12
-rw-r--r--userconfig.patch13
5 files changed, 28 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 625907db3784..be34605d879f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jan 3 10:14:25 UTC 2018
+# Wed Apr 4 17:07:41 UTC 2018
pkgbase = purr-data-git
pkgdesc = Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
- pkgver = 2.4.6.r3765.6b3ae079
+ pkgver = 2.5.0.r3922.cbaa90dd
pkgrel = 1
url = https://git.purrdata.net/jwilkes/purr-data
install = purr-data.install
@@ -18,7 +18,7 @@ pkgbase = purr-data-git
depends = desktop-file-utils
depends = dssi
depends = fftw
- depends = flite1
+ depends = flite
depends = fluidsynth
depends = freeglut
depends = ftgl
@@ -62,11 +62,9 @@ pkgbase = purr-data-git
options = !makeflags
options = !strip
source = purr-data-git::git+https://git.purrdata.net/jwilkes/purr-data.git
- source = RTcmix-pd-LCPLAY-stabilize.patch
source = gem-magick6-fixes.patch
md5sums = SKIP
- md5sums = 39c53063dc18681f29b12c08d9c453aa
- md5sums = 63c6794adbc47e4c239eeb50ed30bfa8
+ md5sums = 6f9b87db6e73a35ec63327e97ad95d66
source_i686 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-ia32.tar.gz
md5sums_i686 = e4708d59006219eaa2c54cdb1d682794
source_x86_64 = http://dl.nwjs.io/v0.22.1/nwjs-sdk-v0.22.1-linux-x64.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3d92f7ff3524..dd220e1e8b56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,14 @@
# /usr/lib/purr-data, so that 3rd party externals know where to find these.
pkgname=purr-data-git
-pkgver=2.4.6.r3765.6b3ae079
+pkgver=2.5.0.r3922.cbaa90dd
pkgrel=1
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
arch=('i686' 'x86_64')
license=('BSD')
depends=('bluez-libs' 'desktop-file-utils' 'dssi' 'fftw'
- 'flite1' 'fluidsynth' 'freeglut' 'ftgl' 'glew' 'gmerlin'
+ 'flite' 'fluidsynth' 'freeglut' 'ftgl' 'glew' 'gmerlin'
'gsl' 'gsm' 'hicolor-icon-theme' 'libmagick6' 'jack' 'ladspa' 'lame'
'libdc1394' 'libdv' 'libgl' 'libiec61883' 'libjpeg' 'libquicktime'
'libxxf86vm' 'libtiff' 'libiec61883' 'libunicap' 'libraw1394'
@@ -45,11 +45,9 @@ conflicts=('purr-data')
install=purr-data.install
options=('!makeflags' '!strip')
source=("$pkgname::git+https://git.purrdata.net/jwilkes/purr-data.git"
- "RTcmix-pd-LCPLAY-stabilize.patch"
"gem-magick6-fixes.patch")
md5sums=('SKIP'
- '39c53063dc18681f29b12c08d9c453aa'
- '63c6794adbc47e4c239eeb50ed30bfa8')
+ '6f9b87db6e73a35ec63327e97ad95d66')
# nw.js sdk binaries
nwjsname=nwjs-sdk
nwjsver=0.22.1
@@ -72,11 +70,10 @@ fi
# pd-l2ork package.
prefix=${prefix:-/opt/purr-data}
-# Run 'makepkg buildopt=-b' for an incremental build (this skips recompiling
-# Gem which takes a *long* time to build). Note that this will only produce a
-# proper package if src still contains the results of a previous full build,
-# otherwise Gem will be missing in the resulting package!
-buildopt=${buildopt:--B}
+# Run 'makepkg buildopt=incremental' for an incremental build (this skips
+# recompiling Gem which takes a *long* time to build) or 'makepkg
+# buildopt=light' for a light one (only essential externals).
+buildopt=${buildopt:-}
pkgver() {
cd $srcdir/$pkgname
@@ -93,24 +90,20 @@ prepare() {
# copy the nw.js sources to where purr-data wants them
rm -rf pd/nw/nw
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
- # make the sources compile with gcc 6.1+
- cd $srcdir/$pkgname/externals/rtcmix-in-pd && patch -Np1 < $srcdir/RTcmix-pd-LCPLAY-stabilize.patch
# make sure to link Gem with ImageMagick 6, it doesn't compile with 7
cd $srcdir/$pkgname && patch -Np1 < $srcdir/gem-magick6-fixes.patch
}
build() {
- unset CFLAGS
- unset LDFLAGS
- unset INCLUDES
-
- cd $srcdir/$pkgname/l2ork_addons
- inst_dir=$prefix ./tar_em_up.sh $buildopt -n
+ unset CFLAGS CPPFLAGS CXXFLAGS DEBUG_CFLAGS DEBUG_CXXFLAGS LDFLAGS INCLUDES
+ cd $srcdir/$pkgname
+ make prefix="$prefix" $buildopt
}
package() {
+ cd $srcdir/$pkgname
+ make install prefix="$prefix" DESTDIR="$pkgdir"
cd "$srcdir/$pkgname/packages/linux_make/build"
- cp -a * "$pkgdir"
# Create a link to the executable.
mkdir -p "$pkgdir/usr/bin"
ln -sf $prefix/bin/pd-l2ork "$pkgdir/usr/bin/purr-data"
@@ -119,12 +112,12 @@ package() {
ln -sf $prefix/include/pd-l2ork "$pkgdir/usr/include/purr-data"
mkdir -p "$pkgdir/usr/lib"
ln -sf $prefix/lib/pd-l2ork "$pkgdir/usr/lib/purr-data"
- # Just remove all the /etc stuff and the Emacs mode for now, we don't really
- # need most of these.
- rm -rf "$pkgdir/etc" "$pkgdir/usr/share/emacs"
- # Add the bash completion file again, and edit it accordingly.
- mkdir -p "$pkgdir/etc/bash_completion.d"
- sed -e 's/pd-l2ork/purr-data/g' < "$srcdir/$pkgname/scripts/bash_completion/pd-l2ork" > "$pkgdir/etc/bash_completion.d/purr-data"
+ # Edit bash completion file.
+ sed -e 's/pd-l2ork/purr-data/g' < "$pkgdir/etc/bash_completion.d/pd-l2ork" > "$pkgdir/etc/bash_completion.d/purr-data"
+ rm -f "$pkgdir/etc/bash_completion.d/pd-l2ork"
+ # For now we just remove the Emacs mode as it will conflict with the
+ # pd-l2ork package.
+ rm -rf "$pkgdir/usr/share/emacs/site-lisp"
# Edit the library paths in the default user.settings file so that it
# matches our install prefix.
cd "$pkgdir$prefix/lib/pd-l2ork"
diff --git a/RTcmix-pd-LCPLAY-stabilize.patch b/RTcmix-pd-LCPLAY-stabilize.patch
deleted file mode 100644
index 20f10a8b1669..000000000000
--- a/RTcmix-pd-LCPLAY-stabilize.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp b/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-index 5753965..9cf85c4 100644
---- a/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-+++ b/RTcmix-pd-4.0.1.6/insts/std/LPCPLAY/stabilize.cpp
-@@ -29,7 +29,7 @@ stabilize(float *frameIn, int npoles)
- static Complex jay(0., 1.);
- static Complex tmp;
-
--inline double abs(double x) { return (x >= 0.) ? x : -x; }
-+//inline double abs(double x) { return (x >= 0.) ? x : -x; }
-
- static int
- factor(double *b, long *k4, double *rootr, double *rooti,
diff --git a/gem-magick6-fixes.patch b/gem-magick6-fixes.patch
index 6f1eb8abe5f1..13a4059e4a50 100644
--- a/gem-magick6-fixes.patch
+++ b/gem-magick6-fixes.patch
@@ -1,15 +1,15 @@
diff --git a/externals/Makefile b/externals/Makefile
-index e60a73c9..09066109 100644
+index 414e1e2e..b7cfa952 100644
--- a/externals/Makefile
+++ b/externals/Makefile
-@@ -658,6 +658,10 @@ $(gem_src)/Gem.pd_linux: $(gem_src)/configure
+@@ -667,6 +667,10 @@ $(gem_src)/Gem.pd_linux: $(gem_src)/configure
test -s $(gem_src)/Gem.pd_linux || \
cd $(gem_src) && ./configure \
CXXFLAGS="-DHAVE_S_STUFF_H" \
-+ PKG_IMAGEMAGICK___CFLAGS="$(shell pkg-config --cflags ImageMagick-6.Q16HDRI)" \
-+ PKG_IMAGEMAGICK___LIBS="$(shell pkg-config --libs ImageMagick-6.Q16HDRI)" \
-+ PKG_MAGICKCORE_CFLAGS="$(shell pkg-config --cflags MagickCore-6.Q16HDRI)" \
-+ PKG_MAGICKCORE_LIBS="$(shell pkg-config --libs MagickCore-6.Q16HDRI)" \
++ PKG_IMAGEMAGICK___CFLAGS="$(shell PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config --cflags ImageMagick-6.Q16HDRI)" \
++ PKG_IMAGEMAGICK___LIBS="$(shell PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config --libs ImageMagick-6.Q16HDRI)" \
++ PKG_MAGICKCORE_CFLAGS="$(shell PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config --cflags MagickCore-6.Q16HDRI)" \
++ PKG_MAGICKCORE_LIBS="$(shell PKG_CONFIG_PATH=/usr/lib/imagemagick6/pkgconfig pkg-config --libs MagickCore-6.Q16HDRI)" \
--prefix=$(prefix) \
--with-video=plugins \
--with-film=plugins \
diff --git a/userconfig.patch b/userconfig.patch
deleted file mode 100644
index 0e41714e92fc..000000000000
--- a/userconfig.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/pd/src/s_file.c b/pd/src/s_file.c
-index 32f54c31..304524d5 100644
---- a/pd/src/s_file.c
-+++ b/pd/src/s_file.c
-@@ -46,7 +46,7 @@ void sys_doflags( void);
-
- #ifdef UNIX
-
--#define USER_CONFIG_DIR ".pd-l2ork"
-+#define USER_CONFIG_DIR ".purr-data"
-
- static char *sys_prefbuf;
-