summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2016-07-04 12:25:39 +0200
committerAlbert Graef2016-07-04 12:25:39 +0200
commitf476ad588c5c3f4343fbb4b72c978dc144e0e727 (patch)
tree6a20561e56bd33677c3498220038968d8ce0c043
parentc5e6bc1f330deef2cd317588c2d08982e6bab8ac (diff)
downloadaur-f476ad588c5c3f4343fbb4b72c978dc144e0e727.tar.gz
PKGBUILD fixes.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0fb6872b72f..2a9ffa2806a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jul 4 06:02:25 UTC 2016
+# Mon Jul 4 10:24:57 UTC 2016
pkgbase = purr-data-git
pkgdesc = Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)
pkgver = r2754.b3ad47a
- pkgrel = 1
+ pkgrel = 2
url = https://git.purrdata.net/jwilkes/purr-data
install = purr-data.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index e8aea845352f..07e25c6cac43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@
pkgname=purr-data-git
pkgver=r2754.b3ad47a
-pkgrel=1
+pkgrel=2
pkgdesc="Jonathan Wilkes' nw.js variant of Pd-L2Ork (git version)"
url="https://git.purrdata.net/jwilkes/purr-data"
arch=('i686' 'x86_64')
@@ -57,6 +57,12 @@ elif [ "$CARCH" = "x86_64" ]; then
_arch="x64"
fi
+# Run 'makepkg buildopt=-b' for an incremental build (this skips recompiling
+# Gem which takes a *long* time to buidl). Note that this will only produce a
+# proper package if src still contains the results of a previous full build,
+# otherwise Gem will be missing in the resulting package!
+buildopt=${buildopt:--B}
+
pkgver() {
cd $srcdir/$pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -64,9 +70,13 @@ pkgver() {
prepare() {
cd $srcdir/$pkgname
+ # first make sure that we get any checked out submodules in pristine state
+ # again, so that our patches apply cleanly
+ git submodule foreach git checkout .
# check out the latest source of all submodules
git submodule update --init
# copy the nw.js sources to where purr-data wants them
+ rm -rf pd/nw/nw
cp -a $srcdir/$nwjsname-v$nwjsver-linux-$_arch pd/nw/nw
# make the sources compile with gcc 6.1+
cd $srcdir/$pkgname/Gem && patch -Np1 < $srcdir/Gem-pix_colorclassify.patch
@@ -79,7 +89,7 @@ build() {
unset INCLUDES
cd $srcdir/$pkgname/l2ork_addons
- ./tar_em_up.sh -B -n
+ ./tar_em_up.sh $buildopt -n
}
package() {
@@ -109,12 +119,12 @@ package() {
chmod -R go-w *
chmod -R a+r *
chmod a-x usr/lib/pd-l2ork/default.settings
- find usr/lib/pd-l2ork/bin/nw -executable -not -type d | xargs chmod a+x
- #find . -executable -name '*.pd_linux' | xargs chmod a-x
- find . -executable -name '*.pd' | xargs chmod a-x
- find . -executable -name '*.txt' | xargs chmod a-x
- find . -executable -name '*.aif*' | xargs chmod a-x
- find . -type d | xargs chmod a+x
+ find usr/lib/pd-l2ork/bin/nw -executable -not -type d -exec chmod a+x {} +
+ #find . -executable -name '*.pd_linux' -exec chmod a-x {} +
+ find . -executable -name '*.pd' -exec chmod a-x {} +
+ find . -executable -name '*.txt' -exec chmod a-x {} +
+ find . -executable -name '*.aif*' -exec chmod a-x {} +
+ find . -type d -exec chmod a+x {} +
}
# vim:set ts=2 sw=2 et: