summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2016-01-23 15:18:08 +0100
committerValHue2016-01-23 15:18:08 +0100
commit902f19f8519400cb466e84d5152c82fb7bb971eb (patch)
tree85489a49ba24d2f64f7ed6e383e29af3fad57f0c
downloadaur-902f19f8519400cb466e84d5152c82fb7bb971eb.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1e188617bfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 14:13:27 UTC 2016
+pkgbase = pushbullet-indicator
+ pkgdesc = An indicator for working with PushBullet.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://www.atareao.es/tag/pushbullet-indicator/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2-distutils-extra
+ makedepends = python2-polib
+ depends = python
+ depends = shared-mime-info
+ depends = python-beautifulsoup4
+ depends = python-jinja
+ depends = python-requests
+ provides = pushbullet-indicator
+ source = https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/pushbullet-indicator_0.6.0-0extras14.04.1.tar.gz
+ sha256sums = b9ff6936c6095d6b81b7331f99965f18e590a04c8086d7d0874782ba2721f3b6
+
+pkgname = pushbullet-indicator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61e553562bbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: ValHue <vhuelamo at gmail dot com>
+#
+pkgname="pushbullet-indicator"
+pkgver="0.6.0"
+pkgrel="1"
+pkgdesc="An indicator for working with PushBullet."
+arch=('i686' 'x86_64')
+url="http://www.atareao.es/tag/pushbullet-indicator/"
+license=('GPL3')
+depends=('python' 'shared-mime-info' 'python-beautifulsoup4' 'python-jinja' 'python-requests')
+makedepends=('python2-distutils-extra' 'python2-polib')
+provides=("${pkgname}")
+source=("https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/${pkgname}_${pkgver}-0extras14.04.1.tar.gz")
+sha256sums=('b9ff6936c6095d6b81b7331f99965f18e590a04c8086d7d0874782ba2721f3b6')
+#install="${pkgname}.install"
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ sed -i "s|os.path.join(ROOTDIR, 'locale-langpack')|'/usr/share/locale/'|g" ./src/comun.py
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mv ./build/locale-langpack ${pkgdir}/usr/share/locale
+
+ cd "${pkgdir}"
+ rm -rf ./opt/extras.ubuntu.com/${pkgname}/share/locale-langpack
+}
+
+# vim:set ts=4 sw=2 ft=sh et: