summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian2018-03-05 00:33:54 +0000
committerAlexander Sulfrian2018-03-05 00:34:42 +0000
commit9a6b8028e4a84930a2cb663b88b3e7db768546cd (patch)
tree03907975bc9522346843305723b4913bb69f39d9
downloadaur-9a6b8028e4a84930a2cb663b88b3e7db768546cd.tar.gz
Initial packaging
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD50
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e1c034f1552
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pusher
+ pkgdesc = Command line client for PushNotifier
+ pkgver = 0.4_1
+ pkgrel = 1
+ url = https://github.com/HackHerz/pusher
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ depends = curl
+ source = pusher::git+https://github.com/HackHerz/pusher#commit=20a492cfe94161fda7692801f64176d45b6afa0b
+ source = pushnotifier-sdk-cpp::git+https://github.com/HackHerz/pushnotifier-sdk-cpp
+ source = simpleini::git+https://github.com/brofield/simpleini
+ source = cppcodec::git+https://github.com/tplgy/cppcodec
+ source = json::git+https://github.com/nlohmann/json
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = pusher
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d5bde33a782
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+src/
+pkg/
+*.pkg.tar.*
+pusher/
+simpleini/
+pushnotifier-sdk-cpp/
+cppcodec/
+json/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4854a7f6b042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
+
+# The current relase v0.4 is broken and we the commit following the
+# release tag, too. So we currently cannot use "#tag=v${pkgver}" in the
+# git url, but we do not want to use git-HEAD.
+
+pkgname=pusher
+pkgver=0.4_1
+pkgrel=1
+pkgdesc="Command line client for PushNotifier"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/HackHerz/pusher"
+license=('GPL3')
+depends=('curl')
+optdepends=()
+makedepends=()
+
+source=("$pkgname::git+https://github.com/HackHerz/pusher#commit=20a492cfe94161fda7692801f64176d45b6afa0b"
+ 'pushnotifier-sdk-cpp::git+https://github.com/HackHerz/pushnotifier-sdk-cpp'
+ 'simpleini::git+https://github.com/brofield/simpleini'
+ 'cppcodec::git+https://github.com/tplgy/cppcodec'
+ 'json::git+https://github.com/nlohmann/json')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.pushnotifier-sdk-cpp.url "$srcdir/pushnotifier-sdk-cpp"
+ git config submodule.simpleini.url "$srcdir/simpleini"
+ git submodule update
+
+ cd "src/pushnotifier-sdk-cpp"
+ git submodule init
+ git config submodule.cppcodec.url "$srcdir/cppcodec"
+ git config submodule.json.url "$srcdir/json"
+ git submodule update
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ # "make install" does not honor DESTDIR and does not create missing
+ # directories.
+ install -Dm755 pusher "$pkgdir/usr/bin/pusher"
+}