summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Plsek2019-03-24 14:04:19 -0400
committerJeremy Plsek2019-03-24 14:05:37 -0400
commit1d8b30c0afa306a321ebd0594330aeb389af4e41 (patch)
treead3046958293c35d3b48ea9206f13226cce98085
parent8b92b5db3a9cf36c8bab0121ba74d86f799a9de4 (diff)
downloadaur-1d8b30c0afa306a321ebd0594330aeb389af4e41.tar.gz
switch to cmake
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e071dae76056..f209de5c849d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = puush-qt
pkgdesc = GUI frontend for puush which will create a system tray icon.
- pkgver = 0.2.2
+ pkgver = 0.2.5
pkgrel = 1
url = https://github.com/jplsek/puush-qt
arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = cmake
depends = scrot
depends = qt5-base
depends = qt5-declarative
diff --git a/PKGBUILD b/PKGBUILD
index e1554b089722..08840b200a2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
-pkgver=0.2.2
+pkgver=0.2.5
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
source=('git+https://github.com/jplsek/puush-qt.git')
md5sums=('SKIP')
-makedepends=('git')
+makedepends=('git' 'cmake')
depends=('scrot' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-quickcontrols2')
build() {
cd "$pkgname"
git submodule init
git submodule update
- qmake PREFIX=/usr puush-qt.pro
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr
make
}
package() {
cd "$pkgname"
- make INSTALL_ROOT="$pkgdir" install
+ make DESTDIR="$pkgdir" install
}