summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Plsek2017-06-21 14:28:45 -0400
committerJeremy Plsek2017-06-21 14:28:45 -0400
commit309df86148a6051fe22b5ccdf7c79029a8968e0b (patch)
treeb6d63ff784e920272f930968b88a7b4d5ca79448
parent5fbe5d1fbe7f869496c94ea14d14e22be02fcb60 (diff)
downloadaur-309df86148a6051fe22b5ccdf7c79029a8968e0b.tar.gz
bump version, remove build dir
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 933b1eb1a39d..e2354fa53193 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = puush-qt
pkgdesc = GUI frontend for puush which will create a system tray icon.
- pkgver = 0.2
- pkgrel = 2
+ pkgver = 0.2.1
+ pkgrel = 1
url = https://github.com/jplsek/puush-qt
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = puush-qt
depends = qt5-declarative
depends = qt5-quickcontrols
depends = qt5-quickcontrols2
- source = git+https://github.com/jplsek/puush-qt.git#branch=more-install
+ source = git+https://github.com/jplsek/puush-qt.git
md5sums = SKIP
pkgname = puush-qt
diff --git a/PKGBUILD b/PKGBUILD
index b716d3d99a6e..d2c81825e75a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
-pkgver=0.2
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
@@ -11,21 +11,16 @@ md5sums=('SKIP')
makedepends=('git')
depends=('scrot' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-quickcontrols2')
-prepare() {
- mkdir "$pkgname"/build
-}
-
build() {
cd "$pkgname"
git submodule init
git submodule update
- cd build
- qmake PREFIX=/usr ../puush-qt.pro
+ qmake PREFIX=/usr puush-qt.pro
make
}
package() {
- cd "$pkgname"/build
+ cd "$pkgname"
make INSTALL_ROOT="$pkgdir" install
}