summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Plsek2017-05-24 23:07:42 +0200
committerJeremy Plsek2017-05-24 23:07:42 +0200
commit5fbe5d1fbe7f869496c94ea14d14e22be02fcb60 (patch)
tree227ec4105be0e9704514b44c3ea2b75364bcb816
parent5d5281beca54fc351abb8dbf0dee64b0e5a4f772 (diff)
downloadaur-5fbe5d1fbe7f869496c94ea14d14e22be02fcb60.tar.gz
fix dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4740a260a2c..933b1eb1a39d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = puush-qt
pkgdesc = GUI frontend for puush which will create a system tray icon.
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jplsek/puush-qt
arch = i686
arch = x86_64
@@ -9,7 +9,10 @@ pkgbase = puush-qt
makedepends = git
depends = scrot
depends = qt5-base
- source = git+https://github.com/jplsek/puush-qt.git
+ depends = qt5-declarative
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ source = git+https://github.com/jplsek/puush-qt.git#branch=more-install
md5sums = SKIP
pkgname = puush-qt
diff --git a/PKGBUILD b/PKGBUILD
index 4e765c5d2500..b716d3d99a6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
pkgname=puush-qt
pkgdesc="GUI frontend for puush which will create a system tray icon."
pkgver=0.2
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="https://github.com/jplsek/puush-qt"
license=('BSD')
source=('git+https://github.com/jplsek/puush-qt.git')
md5sums=('SKIP')
makedepends=('git')
-depends=('scrot' 'qt5-base')
+depends=('scrot' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols' 'qt5-quickcontrols2')
prepare() {
- mkdir $pkgname/build
+ mkdir "$pkgname"/build
}
build() {
- cd $pkgname
+ cd "$pkgname"
git submodule init
git submodule update
cd build
@@ -25,7 +25,7 @@ build() {
}
package() {
- cd $pkgname/build
- make INSTALL_ROOT=$pkgdir install
+ cd "$pkgname"/build
+ make INSTALL_ROOT="$pkgdir" install
}