summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Plsek2016-08-06 06:37:41 -0400
committerJeremy Plsek2016-08-06 06:37:41 -0400
commit7f0cbe34fbaf46e3f20030897cfb4f64a1869bce (patch)
tree0b4134669ac9dc81dd2b08b98c99d38a8f3a8a7e
downloadaur-7f0cbe34fbaf46e3f20030897cfb4f64a1869bce.tar.gz
Initial adding of puush-qt pkgbuild
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11da48fac42c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = puush-qt
+ pkgdesc = GUI frontend for puush which will creates a system tray icon.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/jplsek/puush-qt
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = scrot
+ depends = curl
+ depends = qt5-base
+ source = git+https://github.com/jplsek/puush-qt.git
+ md5sums = SKIP
+
+pkgname = puush-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db5b334370da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jeremy Plsek <jeremy plsek at googlemail dot com>
+pkgname=puush-qt
+pkgdesc="GUI frontend for puush which will creates a system tray icon."
+pkgver=0.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/jplsek/puush-qt"
+license=('BSD')
+source=('git+https://github.com/jplsek/puush-qt.git')
+md5sums=('SKIP')
+makedepends=('git')
+depends=('scrot' 'curl' 'qt5-base')
+
+prepare() {
+ mkdir $pkgname/build
+}
+
+build() {
+ cd $pkgname/build
+ qmake PREFIX=/usr ../src/puush-qt.pro
+ make
+}
+
+package() {
+ cd $pkgname/build
+ make install
+}
+