summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca D'Amico2019-08-21 16:37:18 +0200
committerLuca D'Amico2019-08-21 16:37:18 +0200
commitefb594e1b8515e336b995fc16363f87b186a1edf (patch)
tree1b1d77df63057eb6c897913d3df2b2fd93821d50
downloadaur-efb594e1b8515e336b995fc16363f87b186a1edf.tar.gz
1st AUR commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--puzzle-bobble-grub2-theme.install15
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d405c897d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = puzzle-bobble-grub2-theme
+ pkgdesc = Puzzle Bobble Grub2 Theme
+ pkgver = r5.05e4009
+ pkgrel = 1
+ url = https://github.com/Luca1991/Puzzle-Bobble-Grub2-Theme
+ install = puzzle-bobble-grub2-theme.install
+ arch = any
+ license = GPLv3
+ makedepends = git
+ source = git+https://github.com/Luca1991/Puzzle-Bobble-Grub2-Theme
+ md5sums = SKIP
+
+pkgname = puzzle-bobble-grub2-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebaf954f46f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Luca D'Amico <damico.luca91@live.it>
+
+pkgname=puzzle-bobble-grub2-theme
+pkgver=r5.05e4009
+pkgrel=1
+pkgdesc="Puzzle Bobble Grub2 Theme"
+arch=('any')
+license=('GPLv3')
+depends=()
+optdepends=()
+install="${pkgname}.install"
+url="https://github.com/Luca1991/Puzzle-Bobble-Grub2-Theme"
+source=('git+https://github.com/Luca1991/Puzzle-Bobble-Grub2-Theme')
+makedepends=('git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "Puzzle-Bobble-Grub2-Theme"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/boot/grub/themes/"
+ cp -r "${srcdir}/Puzzle-Bobble-Grub2-Theme/puzzle-bobble" "${pkgdir}/boot/grub/themes/puzzle-bobble"
+}
diff --git a/puzzle-bobble-grub2-theme.install b/puzzle-bobble-grub2-theme.install
new file mode 100644
index 000000000000..1e66900502fd
--- /dev/null
+++ b/puzzle-bobble-grub2-theme.install
@@ -0,0 +1,15 @@
+
+post_install() {
+ echo '/!\ To select this GRUB2 theme: Edit /etc/default/grub and add or modify the GRUB_THEME parameter like this'
+ echo '/!\ Edit /etc/default/grub and add or modify the GRUB_THEME parameter like this:'
+ echo '/!\ GRUB_THEME="/boot/grub/themes/puzzle-bobble/theme.txt"'
+ echo '/!\ and then update your grub configuration using this command:'
+ echo '/!\ sudo grub-mkconfig -o /boot/grub/grub.cfg'
+
+}
+
+post_remove() {
+ echo '/!\ Please update GRUB_THEME parameter in /etc/default/grub with a different theme,'
+ echo '/!\ and update your grub configuration using this command:'
+ echo '/!\ sudo grub-mkconfig -o /boot/grub/grub.cfg'
+}