summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspy2023-01-06 15:30:20 +0100
committerspy2023-01-06 15:30:20 +0100
commit86ba6c2bb8077904c0eab00bbb5aa6fc63acf895 (patch)
tree46f3a819497eb82037ad94d041eb3156964e9e89
downloadaur-86ba6c2bb8077904c0eab00bbb5aa6fc63acf895.tar.gz
update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78df12d682ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = pvc
+ pkgdesc = command line tool to change version of aur packages
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ makedepends = python-pip
+ depends = python
+
+pkgname = pvc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..335cfac86a3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+
+# Maintainer: Alfred Roos alfred@stensatter.se
+pkgname=pvc
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="command line tool to change version of aur packages"
+arch=(x86_64)
+url=""
+license=('GPL')
+groups=()
+depends=(python)
+makedepends=(python-pip)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=()
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ pip install flagser
+ git clone https://github.com/spynetS/pvc.git pvc
+}
+
+package() {
+ cd pvc
+ install -Dm755 ./pvc.py "$pkgdir/usr/bin/pvc"
+}