summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVampireSH2017-01-07 20:02:17 +0800
committerVampireSH2017-01-07 20:02:17 +0800
commitd5e1abb8af69193b0d11c395b8bffd6097848f64 (patch)
tree82441538095e8c8b85503ffaae42551985edaec4
downloadaur-d5e1abb8af69193b0d11c395b8bffd6097848f64.tar.gz
add the pvim
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ff52821d956
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pvim
+ pkgdesc = a script to help you quickly upload the code to cfp-vim
+ pkgver = v0.2
+ pkgrel = 1
+ url = https://github.com/Sherlock-Holo/pvim
+ arch = any
+ license = MPL
+ depends = xclip
+ source = git+https://github.com/Sherlock-Holo/pvim.git
+ md5sums = SKIP
+
+pkgname = pvim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73e46a168b80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Sherlock-Holo <sherlockya@gmail.com>
+# Contributor: Sherlock-Holo <sherlockya@gmail.com>
+
+pkgname=pvim
+pkgver=v0.2
+pkgrel=1
+pkgdesc="a script to help you quickly upload the code to cfp-vim"
+url="https://github.com/Sherlock-Holo/pvim"
+arch=('any')
+license=('MPL')
+depends=('xclip')
+makedpends=('git')
+source=("git+https://github.com/Sherlock-Holo/$pkgname.git")
+md5sums=('SKIP')
+
+package(){
+ cd "${pkgname}"
+
+ # Install
+ install -Dm755 $pkgname.sh "${pkgdir}/usr/bin/${pkgname}"
+}