summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTravnick2015-06-27 15:26:00 +0200
committerTravnick2015-06-27 15:26:00 +0200
commit734fdd80fe7336669f06e29c39be226a9e75938e (patch)
treec10daeeb2a9ed3733c3f196428ce3fc885e5ef93
downloadaur-734fdd80fe7336669f06e29c39be226a9e75938e.tar.gz
Migrated from AUR3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
-rw-r--r--pvm.install25
-rw-r--r--pvm.profile2
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5af71786c9c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pvm
+ pkgdesc = Parallel Virtual Machine
+ pkgver = 3.4.6
+ pkgrel = 5
+ url = http://www.csm.ornl.gov/pvm/
+ install = pvm.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://www.netlib.org/pvm3/pvm3.4.6.tgz
+ source = pvm.profile
+ sha512sums = a8ddb8fc944bbe64d185eeffba0e020f28af4c8175a446511deca55d7c4f5cf62884c8c5dcb03dd9700bcc48368c8dab353e45656094d139385d88fdf34dd78a
+ sha512sums = 8c7a612abd0f9f132900a2e4839d9ac2cbcae88cc3d835b82cdad25c3dddcf03f98542afb4d15ac4360523ce6f36057e1269af28694eebf1621cf5b35d0ca920
+
+pkgname = pvm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93d8720aadb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Contributor: Thomas Zervogiannis <tzervo@gmail.com>
+# Contributor: Philipp Robbel <robbel@gmail.com>
+# Contributor: MikoĊ‚aj Milej <mikolajmm@gmail.com>
+
+pkgname=pvm
+pkgver=3.4.6
+pkgrel=5
+pkgdesc="Parallel Virtual Machine"
+url="http://www.csm.ornl.gov/pvm/"
+license=('GPL')
+depends=('glibc')
+arch=('i686' 'x86_64')
+install=${pkgname}.install
+source=(http://www.netlib.org/pvm3/$pkgname$pkgver.tgz pvm.profile)
+sha512sums=('a8ddb8fc944bbe64d185eeffba0e020f28af4c8175a446511deca55d7c4f5cf62884c8c5dcb03dd9700bcc48368c8dab353e45656094d139385d88fdf34dd78a'
+ '8c7a612abd0f9f132900a2e4839d9ac2cbcae88cc3d835b82cdad25c3dddcf03f98542afb4d15ac4360523ce6f36057e1269af28694eebf1621cf5b35d0ca920')
+
+build() {
+ cd $srcdir/${pkgname}3
+
+ # Make pvm FORTRAN90-friendly
+ sed -i 's/^c/!/' include/fpvm3.h include/fpvm3_watcom.h
+
+ for i in conf/LINUX*def; do
+ sed -i.orig -e '/^ARCHCFLAGS/s~/usr/bin/rsh\\"~/usr/bin/ssh\\" ${CXXFLAGS}~' "${i}"
+ done
+
+ unset PVM_ARCH
+ export PVM_ROOT=$srcdir/${pkgname}3
+ make || return 1
+}
+
+package() {
+ cd $srcdir/${pkgname}3
+
+ mkdir -p $pkgdir/usr/man
+ mv $srcdir/${pkgname}3/man/man1 $pkgdir/usr/man
+ mkdir -p $pkgdir/usr/man/man3
+ mv $srcdir/${pkgname}3/man/man3 $pkgdir/usr/man
+
+ # remove some unnecessary files
+ # rm -rf Readme.* Makefile* WIN32 examples gexamples conf console make* cygwin.mak doc hoster libfpvm man misc pvmgs rm shmd src tasker tracer xdr xep
+ # find . -name '*.cmd' -o -name '*.bat' -o -name '*.stub' | xargs rm -f
+
+ # install the rest of pvm
+ mkdir -p $pkgdir/usr/share/${pkgname}3
+ cp -r * $pkgdir/usr/share/${pkgname}3
+ mkdir -p $pkgdir/usr/bin
+ ln -s /usr/share/pvm3/lib/LINUX/pvm $pkgdir/usr/bin/pvm
+ ln -s /usr/share/pvm3/lib/LINUX/pvmd3 $pkgdir/usr/bin/pvmd3
+ ln -s /usr/share/pvm3/lib/LINUX/pvmgs $pkgdir/usr/bin/pvmgs
+
+ # environment variables
+ mkdir -p $pkgdir/etc/profile.d
+ install -m755 $startdir/${pkgname}.profile $pkgdir/etc/profile.d/${pkgname}3.sh
+}
diff --git a/pvm.install b/pvm.install
new file mode 100644
index 000000000000..ccfc97b2aa62
--- /dev/null
+++ b/pvm.install
@@ -0,0 +1,25 @@
+post_install() {
+ echo "-----------------------------------------------"
+ echo "Environment variables have changed. Either log"
+ echo "out and back in or source /etc/profile before"
+ echo "using pvm!"
+ echo ""
+ echo "NOTE: To enable other computers to invoke the"
+ echo " PVM daemon on your machine, add the"
+ echo " source /etc/profile.d/pvm3.sh"
+ echo " command to your .bashrc"
+ echo "-----------------------------------------------"
+}
+
+post_upgrade() {
+/bin/true
+}
+
+pre_remove() {
+/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/pvm.profile b/pvm.profile
new file mode 100644
index 000000000000..29c9d0edf130
--- /dev/null
+++ b/pvm.profile
@@ -0,0 +1,2 @@
+export PVM_ROOT=/usr/share/pvm3
+export PVM_ARCH=LINUX