summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2022-02-04 18:42:57 -0500
committerNathan Robinson2022-02-04 18:42:57 -0500
commitf408a523b5e68bb5a872fab494040e57ee8032a1 (patch)
tree6397f191599683a687bba9e026ddb2232c527dcf
parent57dc554d7a8ba9c6cd9227e58a968518fba61c96 (diff)
downloadaur-f408a523b5e68bb5a872fab494040e57ee8032a1.tar.gz
Update to 2021.2
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore8
-rw-r--r--LICENSE3
-rw-r--r--PKGBUILD16
4 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c36457039b5d..8db14be90a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pvr-tex-tool-bin
pkgdesc = A comprehensive texture processing and compression tool with support for PVR textures.
- pkgver = 2020.2
- pkgrel = 9
+ pkgver = 2021.2
+ pkgrel = 1
url = https://www.imaginationtech.com/developers/powervr-sdk-tools/pvrtextool/
arch = x86_64
license = custom
@@ -12,12 +12,11 @@ pkgbase = pvr-tex-tool-bin
depends = freetype2
depends = hicolor-icon-theme
options = !strip
- source = install.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-2020_R2.run-x64
+ source = install_2021_R2.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-2021_R2.run-x64
source = LICENSE
source = PVRTexTool.desktop
- sha256sums = 5f6bea49943e52d2f59541efca0bce8c1f841f9a5baf1a193c94cd0e1fcb4a31
- sha256sums = aced963c85df3e08a1a190cdb346e67bcf3621fe198a17ea99e20f787aa60e51
+ sha256sums = 64f321c5e220cef8e4bff2c282c61139031fd9ef3d1d54b1031d056863308216
+ sha256sums = 837064152c1e86d030f76e9beb8da77869f8d8bc183fd8c8a26be696120b5ff4
sha256sums = 2172168dd08d1945ed750bd5ec748731e8b068afe705e956862081ec503ed86f
pkgname = pvr-tex-tool-bin
-
diff --git a/.gitignore b/.gitignore
index 6cf0b008e527..3c2a4e4a9d6d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
-install.run
-LICENSE.html
-LICENSE.txt
+*.run
+LICENSE
pkg
src
-*.tar.xz \ No newline at end of file
+*.tar.xz
+*.tar.zst
diff --git a/LICENSE b/LICENSE
index 4c32dd7475a7..6ae8d6d708de 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,6 +1,5 @@
Adapted from:
-https://www.imaginationtech.com/developers/powervr-sdk-tools/powervr-tools-softw
-are-eula/
+https://www.imaginationtech.com/developers/powervr-sdk-tools/powervr-tools-software-eula/
PLEASE READ THIS AGREEMENT CAREFULLY. BY USING ANY PORTION OF THE POWERVR TOOLS
SOFTWARE YOU WILL BE LEGALLY BOUND TO THESE TERMS.
diff --git a/PKGBUILD b/PKGBUILD
index 1e671cb6c356..056521bd8ab6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Nathan Robinson <nrobinson2000 at me dot com>
pkgname=pvr-tex-tool-bin
-pkgver=2020.2
-_versionstr='2020_R2'
-pkgrel=9
+pkgver=2021.2
+_versionstr='2021_R2'
+pkgrel=1
pkgdesc="A comprehensive texture processing and compression tool with support for PVR textures."
url="https://www.imaginationtech.com/developers/powervr-sdk-tools/pvrtextool/"
@@ -12,12 +12,12 @@ arch=('x86_64')
options=('!strip')
license=('custom')
-source=("install.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-${_versionstr}.run-x64"
+source=("install_${_versionstr}.run::https://cdn.imgtec.com/sdk/OFFLINE/PVRTexToolSetup-${_versionstr}.run-x64"
"LICENSE"
"PVRTexTool.desktop")
-sha256sums=('5f6bea49943e52d2f59541efca0bce8c1f841f9a5baf1a193c94cd0e1fcb4a31'
- 'aced963c85df3e08a1a190cdb346e67bcf3621fe198a17ea99e20f787aa60e51'
+sha256sums=('64f321c5e220cef8e4bff2c282c61139031fd9ef3d1d54b1031d056863308216'
+ '837064152c1e86d030f76e9beb8da77869f8d8bc183fd8c8a26be696120b5ff4'
'2172168dd08d1945ed750bd5ec748731e8b068afe705e956862081ec503ed86f')
# discovered with namcap(1)
@@ -27,8 +27,8 @@ package() {
_srcname=PVRTexTool
# Run installer
-chmod +x "${srcdir}/install.run"
-"${srcdir}/install.run" --prefix "${srcdir}" --mode unattended
+chmod +x "${srcdir}/install_${_versionstr}.run"
+"${srcdir}/install_${_versionstr}.run" --prefix "${srcdir}" --mode unattended
# Install license
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"