summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2023-05-18 22:41:12 +0200
committerClaudia2023-05-18 22:41:12 +0200
commite469f4489b4b61e5c457b06c78c8ea0e70f23bdd (patch)
tree0cb450f9d6a8d0cdce322a52354b9695685c4470
parent117952d0729e80388352c8617c0a60156c1a33a7 (diff)
downloadaur-e469f4489b4b61e5c457b06c78c8ea0e70f23bdd.tar.gz
Adopt package; pwclient v2.6.2
Thanks to user @leuko for suggesting the `PBR_VERSION` workaround.
-rw-r--r--.SRCINFO13
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
4 files changed, 54 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2671191425f0..a84597bbe9da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = pwclient
pkgdesc = The command-line client for the patchwork patch tracking tool
- pkgver = 2.0.0
+ pkgver = 2.6.2
pkgrel = 1
url = https://github.com/getpatchwork/pwclient
arch = any
license = GPL
- checkdepends = python-pytest
checkdepends = python-mock
+ checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = python-pbr
- source = https://github.com/getpatchwork/pwclient/archive/2.0.0.tar.gz
- sha256sums = 33fa25cd1839806f700304ab839ca910ea2b45cf1c1deba909cd0a76aba03e55
+ makedepends = python-wheel
+ depends = python-importlib-metadata
+ source = pwclient-2.6.2.tar.gz::https://github.com/getpatchwork/pwclient/archive/2.6.2.tar.gz
+ sha256sums = 34865de1744a19f3b36f2223cbdb6fc17085edd26e7800b7d2b381bc0a1dec5c
pkgname = pwclient
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
index b73905529f23..6bf3c6300ec4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,5 +9,6 @@
*.log.*
*.sig
-pkg/
-src/
+/.vscode/
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
index 1552b342bb9a..17441a20daa7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
-# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+# Contributor: Alex Dewar <alex.dewar@gmx.co.uk>
pkgname=pwclient
-pkgver=2.0.0
+pkgver=2.6.2
pkgrel=1
-pkgdesc="The command-line client for the patchwork patch tracking tool"
-arch=(any)
+pkgdesc='The command-line client for the patchwork patch tracking tool'
+arch=('any')
url="https://github.com/getpatchwork/$pkgname"
license=('GPL')
-depends=(python-pbr)
-makedepends=(python-setuptools)
-checkdepends=(python-pytest python-mock)
-source=("$url/archive/$pkgver.tar.gz")
-sha256sums=('33fa25cd1839806f700304ab839ca910ea2b45cf1c1deba909cd0a76aba03e55')
+depends=('python-importlib-metadata')
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+checkdepends=('python-mock' 'python-pytest')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('34865de1744a19f3b36f2223cbdb6fc17085edd26e7800b7d2b381bc0a1dec5c')
build() {
- cd "$pkgname-$pkgver"
- python setup.py build
+ cd "$pkgname-$pkgver"
+ PBR_VERSION="$pkgver" python -m build --wheel --no-isolation
}
check() {
- cd "$pkgname-$pkgver"
- pytest
+ cd "$pkgname-$pkgver"
+ pytest
}
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
- mkdir -p "$pkgdir/usr/share/man/man1"
- install -Dm644 man/pwclient.1 "$pkgdir/usr/share/man/man1/"
+ cd "$pkgname-$pkgver"
+ python -I -m installer --destdir="$pkgdir" dist/*.whl
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ install -Dm644 man/pwclient.1 "$pkgdir/usr/share/man/man1/"
}