summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2022-12-07 02:10:51 +0200
committerDimitris Kiziridis2022-12-07 02:10:51 +0200
commit5fd686e7fca9e405ac4528ef1137b7bc9c1f4582 (patch)
tree4510419afe260a796f03a0a1cfb931f0179cb06a
parent7915d53ba180aa9164b4d69b5f7380108b3a9b74 (diff)
downloadaur-pwncat.tar.gz
Fix build error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d2a777ad3f86..6d3466854816 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pwncat
pkgdesc = Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)
pkgver = 0.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://cytopia.github.io/pwncat
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 30baf476244d..573e6e4c2805 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pwncat
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)'
arch=('any')
url='https://cytopia.github.io/pwncat'
@@ -12,10 +12,14 @@ makedepends=('python-setuptools')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cytopia/pwncat/archive/v${pkgver}.tar.gz")
sha256sums=('bca4deb557d4341a6ae3695cd42b9571c247ac4d81dca141e3b26119621a79fd')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ sed -i '14i py_modules=[],' setup.py
+}
+
build() {
cd "${pkgname}-${pkgver}"
python setup.py build
- gzip --force man/pwncat.1
}
package() {
@@ -23,6 +27,6 @@ package() {
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm644 man/pwncat.1.gz -t "${pkgdir}/usr/share/man/man1"
+ install -Dm644 man/pwncat.1 -t "${pkgdir}/usr/share/man/man1"
}
# vim:set ts=2 sw=2 et: