summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-23 15:59:24 +0300
committerDimitris Kiziridis2020-06-23 15:59:24 +0300
commitb0d98bdbed1117723e81c66c4fe0178e82f8d0a1 (patch)
treee72da52af105cd0baf257797bd5c71b3d5e94a2e
parent597fd428cb9ce5f5f88e964ae0d7d578a1778e2b (diff)
downloadaur-b0d98bdbed1117723e81c66c4fe0178e82f8d0a1.tar.gz
Update to 0.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a0a8d5c7d9..2b711a85936b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = pwncat
pkgdesc = Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)
- pkgver = 0.0.22.alpha
+ pkgver = 0.1.0
pkgrel = 1
url = https://cytopia.github.io/pwncat
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = pwncat-0.0.22.alpha.tar.gz::https://github.com/cytopia/pwncat/archive/v0.0.22-alpha.tar.gz
- sha256sums = 23b67ad1e83511953b4d8bae45f1b1a971cee29426e599adb16b15e17fde5dfe
+ source = pwncat-0.1.0.tar.gz::https://github.com/cytopia/pwncat/archive/v0.1.0.tar.gz
+ sha256sums = c3abc7b7a49a79d97c87e04bfafb2d0e99c7e7bec1e784aa15979f289c4c6046
pkgname = pwncat
diff --git a/PKGBUILD b/PKGBUILD
index 4322f539ce0e..74ec44f7a2cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=pwncat
-pkgver=0.0.22.alpha
-_pkgver=0.0.22-alpha
+pkgver=0.1.0
pkgrel=1
pkgdesc='Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)'
arch=('any')
@@ -10,18 +9,18 @@ url='https://cytopia.github.io/pwncat'
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cytopia/pwncat/archive/v${_pkgver}.tar.gz")
-sha256sums=('23b67ad1e83511953b4d8bae45f1b1a971cee29426e599adb16b15e17fde5dfe')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cytopia/pwncat/archive/v${pkgver}.tar.gz")
+sha256sums=('c3abc7b7a49a79d97c87e04bfafb2d0e99c7e7bec1e784aa15979f289c4c6046')
build() {
- cd "${pkgname}-${_pkgver}"
+ cd "${pkgname}-${pkgver}"
python setup.py build
gzip --force man/pwncat.1
}
package() {
- cd "${pkgname}-${_pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dm644 man/pwncat.1.gz -t "${pkgdir}/usr/share/man/man1"