summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-29 00:36:18 +0300
committerDimitris Kiziridis2020-05-29 00:36:18 +0300
commit768cc014fb5ecefaa67ed3ac27569f84a1caacb0 (patch)
tree5d66f29d1f3c58ae4ce310b0138aff422d9b1547
downloadaur-768cc014fb5ecefaa67ed3ac27569f84a1caacb0.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63861cab6d14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pwncat-git
+ pkgdesc = Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)
+ pkgver = 0.0.22.alpha.r0.gf0e70d6
+ pkgrel = 1
+ url = https://cytopia.github.io/pwncat
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ provides = pwncat
+ source = git+https://github.com/cytopia/pwncat
+ sha256sums = SKIP
+
+pkgname = pwncat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d67f5e137ad1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=pwncat-git
+pkgver=0.0.22.alpha.r0.gf0e70d6
+pkgrel=1
+pkgdesc='Netcat on steroids with Firewall, IDS/IPS evasion, bind and reverse shell, self-injecting shell and port forwarding magic - and its fully scriptable with Python (PSE)'
+arch=('any')
+url='https://cytopia.github.io/pwncat'
+license=('MIT')
+provides=('pwncat')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+source=("git+https://github.com/cytopia/pwncat")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pwncat
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd pwncat
+ python setup.py build
+ gzip --force man/pwncat.1
+}
+
+package() {
+ cd pwncat
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 *.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 man/pwncat.1.gz -t "${pkgdir}/usr/share/man/man1"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file