summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-08-17 23:50:15 +0200
committeranthraxx2016-08-18 00:08:26 +0200
commita583e732d97af713d841cbefd0857bcbda6e862f (patch)
treeb9e2366913ac3fce23b1d545301757e4b0038f34
downloadaur-a583e732d97af713d841cbefd0857bcbda6e862f.tar.gz
addpkg: pwndbg-git 0.0.0.430.9905d43-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3abde2509a17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Wed Aug 17 22:08:26 UTC 2016
+pkgbase = pwndbg-git
+ pkgdesc = Makes debugging with GDB suck less
+ pkgver = 0.0.0.430.9905d43
+ pkgrel = 1
+ url = https://github.com/pwndbg/pwndbg
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-capstone
+ depends = python-unicorn
+ depends = python-pycparser
+ depends = python-psutil
+ depends = python-pyelftools
+ depends = python-six
+ provides = pwndbg
+ conflicts = pwndbg
+ source = pwndbg-git::git+https://github.com/pwndbg/pwndbg
+ sha512sums = SKIP
+
+pkgname = pwndbg-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed7fc46311f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=pwndbg-git
+pkgver=0.0.0.430.9905d43
+pkgrel=1
+pkgdesc='Makes debugging with GDB suck less'
+url='https://github.com/pwndbg/pwndbg'
+arch=('any')
+license=('MIT')
+depends=('python-capstone' 'python-unicorn' 'python-pycparser' 'python-psutil' 'python-ptrace' 'python-pyelftools' 'python-six')
+depends=('python-capstone' 'python-unicorn' 'python-pycparser' 'python-psutil' 'python-pyelftools' 'python-six')
+makedepends=('git')
+provides=('pwndbg')
+conflicts=('pwndbg')
+source=(${pkgname}::git+https://github.com/pwndbg/pwndbg)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" \
+ "0.0.0" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed '/0L/d' -i ida_script.py
+}
+
+build() {
+ cd ${pkgname}
+ python -m compileall .
+ python -O -m compileall .
+}
+
+package() {
+ cd ${pkgname}
+ install -d "${pkgdir}/usr/share/pwndbg"
+ cp -r *.py pwndbg __pycache__ "${pkgdir}/usr/share/pwndbg"
+ install -Dm 644 README.md FEATURES.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: