summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-11-24 13:52:22 +0100
committerCarsten Feuls2015-11-24 13:52:22 +0100
commitfed3cf562037d77a087d96137c3224cfd713e678 (patch)
tree877c17102aed21beaf88c66195c6463aa6495502
downloadaur-fed3cf562037d77a087d96137c3224cfd713e678.tar.gz
Initial Commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d00c7d781e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pwstore-git
+ pkgdesc = Multi User Password store
+ pkgver = 38745c9
+ pkgrel = 1
+ url = https://github.com/formorer/pwstore
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ depends = ruby
+ options = !emptydirs
+ source = pwstore-git::git+https://github.com/formorer/pwstore.git
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = pwstore-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c5c85a6e262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Carsten Feuls <archlinux at carstenfeuls dot de>
+
+pkgname=pwstore-git
+pkgver=38745c9
+pkgrel=1
+pkgdesc="Multi User Password store"
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="https://github.com/formorer/pwstore"
+license=('')
+depends=('ruby')
+source=('pwstore-git::git+https://github.com/formorer/pwstore.git')
+options=('!emptydirs')
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --always | sed 's|-|.|g'
+}
+
+
+package() {
+ cd ${srcdir}/${pkgname}
+ mkdir -p "${pkgdir}/usr/bin"
+ cp pws "${pkgdir}/usr/bin/"
+}
+