summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-07-01 14:17:27 -0400
committeracxz2022-07-01 14:17:27 -0400
commit4884e1dd892ed3482f81de122b9b5fad8ae5ef18 (patch)
treeec614a6eebf8de1f78e8d4655fc8f376e9e7f18c
parent9cf2cb83a9a2e333540cb42a8b3398d5af5f83d4 (diff)
downloadaur-py++.tar.gz
add deps
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48541e94c607..ff21bde51297 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = py++
pkgdesc = Py++ - Boost.Python code generator
pkgver = 1.8.4
- pkgrel = 1
+ pkgrel = 2
url = https://pyplusplus.readthedocs.io/en/latest/
arch = i686
arch = x86_64
license = Boost Software License
+ makedepends = python
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
depends = python-pygccxml
depends = castxml
diff --git a/PKGBUILD b/PKGBUILD
index b1bdc6b76c6e..dea2d37d96ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,23 @@
# Contributor: zarra <zarraxx@gmail.com>
pkgname=py++
pkgver=1.8.4
-pkgrel=1
+pkgrel=2
pkgdesc="Py++ - Boost.Python code generator"
arch=('i686' 'x86_64')
url="https://pyplusplus.readthedocs.io/en/latest/"
license=('Boost Software License')
depends=('python' 'python-pygccxml' 'castxml')
+makedepends=('python' 'python-build' 'python-installer' 'python-wheel'
+ 'python-setuptools')
source=("https://github.com/ompl/pyplusplus/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('10379d3b2c78612d9097a6533b4da5ad91f91377022bb6f6052549579b4991ee')
build() {
cd "$srcdir/pyplusplus-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/pyplusplus-${pkgver}"
- python setup.py install --prefix=/usr --root=$pkgdir
+ python -m installer --destdir="$pkgdir" dist/*.whl
}