summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-06-12 20:35:27 +0900
committerBenjamin Chrétien2013-06-12 20:47:42 +0900
commit90adcb0ac241ec2109346682ee02eb1b25ecc9f0 (patch)
tree0dc5a59762f1c0e28d8afd360d259af518b54bd4
downloadaur-90adcb0ac241ec2109346682ee02eb1b25ecc9f0.tar.gz
Add original py++ and py++-svn PKGBUILDs.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3778d84c1e3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = py++
+ pkgdesc = Py++ package and Boost.Python library provide a complete solution for interfacing Python and C++
+ pkgver = 1.0.0
+ pkgrel = 2
+ url = http://www.language-binding.net/index.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pygccxml
+ options = !strip
+ source = http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pyplusplus-1.0.0.zip
+ md5sums = 4997f61fa27a432e36fa0142dc3dc06c
+
+pkgname = py++
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3fc26ac598b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: zarra <zarraxx@gmail.com>
+pkgname=py++
+pkgver=1.0.0
+pkgrel=2
+pkgdesc="Py++ package and Boost.Python library provide a complete solution for interfacing Python and C++"
+arch=('i686' 'x86_64')
+url="http://www.language-binding.net/index.html"
+license=('custom')
+depends=('pygccxml')
+options=(!strip)
+
+
+source=(http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pyplusplus-${pkgver}.zip)
+
+md5sums=('4997f61fa27a432e36fa0142dc3dc06c')
+
+
+build() {
+ cd "$srcdir/Py++-${pkgver}"
+
+ python2 setup.py build || return 1
+ python2 setup.py install --prefix=/usr --root=$startdir/pkg
+
+}
+
+# vim:set ts=2 sw=2 et: