summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-06-12 21:28:15 +0900
committerBenjamin Chrétien2013-06-12 21:28:15 +0900
commit943f900274abdcdd264ce7a289cd5ddc977093fa (patch)
treeb7f91f068f45cd20ffe205ada7aa63bc04930b0e
parentc41c24ff96eaf72abcd6ce93e281d5f51af105df (diff)
downloadaur-py++-svn.tar.gz
Update py++ and py++-svn PKGBUILDs.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc0fa2e0f05c..99d2022f71bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = py++-svn
pkgdesc = Py++ package and Boost.Python library provide a complete solution for interfacing Python and C++
pkgver = 1856
- pkgrel = 1
+ pkgrel = 2
url = http://www.language-binding.net/index.html
arch = i686
arch = x86_64
license = custom
makedepends = subversion
depends = pygccxml
+ depends = python2
provides = py++
conflicts = py++
+ source = pyplusplus::svn://svn.code.sf.net/p/pygccxml/svn/pyplusplus_dev
+ md5sums = SKIP
pkgname = py++-svn
diff --git a/PKGBUILD b/PKGBUILD
index 52c9f89db1e9..1a2b7783daea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
+# Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
pkgname=py++-svn
pkgver=1856
-pkgrel=1
+pkgrel=2
pkgdesc="Py++ package and Boost.Python library provide a complete solution for interfacing Python and C++"
arch=('i686' 'x86_64')
-arch=('i686' 'x86_64')
url="http://www.language-binding.net/index.html"
-depends=('pygccxml')
+depends=('pygccxml' 'python2')
makedepends=('subversion')
provides=('py++')
conflicts=('py++')
license=('custom')
+md5sums=('SKIP')
-_svntrunk="http://pygccxml.svn.sourceforge.net/svnroot/pygccxml/pyplusplus_dev"
_svnmod="pyplusplus"
+source=("$_svnmod::svn://svn.code.sf.net/p/pygccxml/svn/pyplusplus_dev")
+
+pkgver() {
+ cd "$srcdir/$_svnmod"
+ svnversion | tr -d [A-z]
+}
build() {
- cd "$srcdir"
- mkdir -p root
- msg "Connecting to pyplusplus SVN server......."
- svn co "$_svntrunk" "$_svnmod"
- msg "Starting make..."
- cd "$_svnmod"
- python2 setup.py install --prefix=../root/
+ cd "$srcdir/$_svnmod"
+ python2 setup.py build
}
package() {
- cp -r "$srcdir"/root/ "$pkgdir"/usr/
-} \ No newline at end of file
+ cd "$srcdir/$_svnmod"
+ python2 setup.py install --prefix=/usr --root=$pkgdir
+}