summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2015-09-12 12:36:52 +0300
committerJesse Jaara2015-09-12 12:37:26 +0300
commitd1933b0d2baea05fdbf6e7ec76b76429580ae075 (patch)
tree36c34e624ea44208d0929c5f3c5fa5f7eafbcf98
downloadaur-d1933b0d2baea05fdbf6e7ec76b76429580ae075.tar.gz
Create AUR package for py-trello.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..380498c112a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = py-trello
+ pkgdesc = Python wrapper around the Trello API
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://github.com/sarumont/py-trello
+ arch = any
+ license = BSD
+ depends = python-requests-oauthlib
+ depends = python-dateutil
+ source = https://github.com/sarumont/py-trello/archive/0.4.3.tar.gz
+ md5sums = cbc966b6e533a140ad4fe746e27f79e3
+
+pkgname = py-trello
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ed3c6dbd460
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
+
+pkgname=py-trello
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="Python wrapper around the Trello API"
+arch=(any)
+url="https://github.com/sarumont/py-trello"
+license=("BSD")
+depends=("python-requests-oauthlib" "python-dateutil")
+source=("https://github.com/sarumont/py-trello/archive/0.4.3.tar.gz")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+md5sums=('cbc966b6e533a140ad4fe746e27f79e3')