summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormcgillij2021-04-10 21:35:50 -0300
committermcgillij2021-04-10 21:35:50 -0300
commit6f8255b0ba6a79f713241a79cec61a856815b5f1 (patch)
tree397190fdb8bf00010f3ae37e491ed719fc697c4b
downloadaur-6f8255b0ba6a79f713241a79cec61a856815b5f1.tar.gz
initial commit for py3status-amdfan AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7574987e2264
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = py3status-amdfan
+ pkgdesc = Py3status module for monitoring fan and temp of amdgpu video cards
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/mcgillij/py3status-amdfan
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = py3status
+ depends = amdfan
+ source = https://github.com/mcgillij/py3status-amdfan/releases/download/0.1.0/py3status-amdfan-0.1.0.tar.gz
+ md5sums = 29a3049752241334ab2fa8e7ef9ae28f
+
+pkgname = py3status-amdfan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80a9d746417a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jason McGillivray < mcgillivray dot jason at gmail dot com>
+
+
+pkgname=py3status-amdfan
+pkgdesc="Py3status module for monitoring fan and temp of amdgpu video cards"
+pkgver=0.1.0
+pkgrel=1
+arch=('any')
+license=('MIT')
+depends=('python' 'py3status' 'amdfan')
+makedepends=('python-setuptools')
+url="https://github.com/mcgillij/py3status-amdfan"
+source=("https://github.com/mcgillij/py3status-amdfan/releases/download/0.1.0/py3status-amdfan-0.1.0.tar.gz")
+md5sums=('29a3049752241334ab2fa8e7ef9ae28f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+}