summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-02-09 09:19:50 +0100
committera8212024-02-09 09:19:50 +0100
commit5a4a5ac7057ed4d42c69878785ded7257ad53fb4 (patch)
treec49c304ca4607838b1e64c9a4410655b42f941ed
parent050e992aea0d1e93c13199bac90a0106713ff028 (diff)
downloadaur-pyalpm-git.tar.gz
Update PKGBUILD
* add SPDX license * remove merged request #19
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 24 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aad9e1a6eb2f..ed1b1639eb9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.10.6.r9.g90941d0
+ pkgver = 0.10.6.r11.gc8d9eeb
pkgrel = 1
- url = https://git.archlinux.org/pyalpm.git/
+ url = https://gitlab.archlinux.org/archlinux/pyalpm
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
checkdepends = python-pytest
checkdepends = python-pytest-pacman
makedepends = git
makedepends = python-setuptools
makedepends = python-pkgconfig
- depends = python>=3.6
- depends = pacman>=5
- provides = pyalpm=0.10.6.r9.g90941d0
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ depends = python
+ depends = pacman
+ provides = pyalpm
conflicts = pyalpm
source = git+https://gitlab.archlinux.org/archlinux/pyalpm.git
- source = pyalpm-mr19.patch::https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/19.patch
sha256sums = SKIP
- sha256sums = 78098e9ebdc2e90846cb836913edab0ca74abdf5c8e846468063300a017d5fb7
pkgname = pyalpm-git
diff --git a/PKGBUILD b/PKGBUILD
index 43074b0af8e5..a0f230ecf40b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,24 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: a821
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
# Contributor: bartus
# Contributor: Rémy Oudompheng <remy@archlinux.org>
# Contributor: Dave Reisner <d@falconindy.com>
-_pkgname=pyalpm
-pkgname=$_pkgname-git
-pkgver=0.10.6.r9.g90941d0
+pkgname=pyalpm-git
+_pkgname=${pkgname%-git}
+pkgver=0.10.6.r11.gc8d9eeb
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('x86_64')
-url="https://git.archlinux.org/pyalpm.git/"
-license=('GPL3')
-depends=('python>=3.6' 'pacman>=5')
-makedepends=('git' 'python-setuptools' 'python-pkgconfig')
+url="https://gitlab.archlinux.org/archlinux/pyalpm"
+license=('GPL-3.0-only')
+depends=('python' 'pacman')
+makedepends=('git' 'python-setuptools' 'python-pkgconfig' 'python-wheel' 'python-build' 'python-installer')
checkdepends=('python-pytest' 'python-pytest-pacman')
-provides=("$_pkgname=$pkgver")
-conflicts=("$_pkgname")
-source=('git+https://gitlab.archlinux.org/archlinux/pyalpm.git'
- 'pyalpm-mr19.patch::https://gitlab.archlinux.org/archlinux/pyalpm/-/merge_requests/19.patch')
-sha256sums=('SKIP'
- '78098e9ebdc2e90846cb836913edab0ca74abdf5c8e846468063300a017d5fb7')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
@@ -28,25 +27,17 @@ pkgver() {
)
}
-prepare() {
- cd $_pkgname
- patch -Np1 -i ../pyalpm-mr19.patch
-}
-
build() {
cd $_pkgname
-
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd $_pkgname
-
PYTHONPATH="$(ls -d build/lib.linux-$CARCH-*)" pytest -v test
}
package() {
cd $_pkgname
-
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}